Fax Detection

Can anyone help me get fax detection working? We have faxing coming in on a POTS line over a Digium AEX410 card. We have it configured so any incoming call over that line is routed to a specific incoming route and have verified it is working.

faxdetect is put on the stack during an incoming call, but ignored.

FFA is installed.

Originial Install was AsteriskNOW 1.7.1
FreePBX 2.9.0.7
Asterisk 1.6.2.20
Server is x64

fax show licensesFax Licensing Information

Free fax licenses: 1
Total licensed ports: 1

Licenses Found:
File: FFA-WGL63BTZBG7G.lic – Key: FFA-WGL63BTZBG7G – Product: RESFFA – Host-ID: b6:32:63:66:e9:c5:2a:82:9e:37:be:83:51:5b:64:ff:eb:9b:d0:ae – Ports: 1 (OK)

fax show capabilities

Registered FAX Technology Modules:

Type : DIGIUM
Description : Digium FAX Driver
Capabilities : SEND RECEIVE T.38 G.711 MULTI-DOC

1 registered modules

fax show stats
FAX Statistics:

Current Sessions : 0
Reserved Sessions : 0
Transmit Attempts : 0
Receive Attempts : 0
Completed FAXes : 0
Failed FAXes : 0

Digium G.711
Licensed Channels : 1
Max Concurrent : 0
Success : 0
Switched to T.38 : 0
Canceled : 0
No FAX : 0
Partial : 0
Negotiation Failed : 0
Train Failure : 0
Protocol Error : 0
IO Partial : 0
IO Fail : 0

Digium T.38
Licensed Channels : 1
Max Concurrent : 0
Success : 0
Canceled : 0
No FAX : 0
Partial : 0
Negotiation Failed : 0
Train Failure : 0
Protocol Error : 0
IO Partial : 0
IO Fail : 0

Here is a log of an incoming call on the POTS line.

– Starting simple switch on ‘DAHDI/1-1’
– Executing [[email protected]:1] NoOp(“DAHDI/1-1”, "Entering from-dahdi with DID == ") in new stack
– Executing [[email protected]:2] Ringing(“DAHDI/1-1”, “”) in new stack
– Executing [[email protected]:3] Set(“DAHDI/1-1”, “DID=s”) in new stack
– Executing [[email protected]:4] NoOp(“DAHDI/1-1”, “DID is now s”) in new stack
– Executing [[email protected]:5] GotoIf(“DAHDI/1-1”, “1?dahdiok:checkzap”) in new stack
– Goto (from-zaptel,s,9)
– Executing [[email protected]:9] NoOp(“DAHDI/1-1”, “Is a DAHDi Channel”) in new stack
– Executing [[email protected]:10] Set(“DAHDI/1-1”, “CHAN=1-1”) in new stack
– Executing [[email protected]:11] Set(“DAHDI/1-1”, “CHAN=1”) in new stack
– Executing [[email protected]:12] Macro(“DAHDI/1-1”, “from-dahdi-1,s,1”) in new stack
– Executing [[email protected]:1] NoOp(“DAHDI/1-1”, “Entering macro-from-dahdi-1 with DID = s and setting to: 9205320428”) in new stack
– Executing [[email protected]:2] Set(“DAHDI/1-1”, “__FROM_DID=9205320428”) in new stack
– Executing [[email protected]:3] Goto(“DAHDI/1-1”, “from-trunk,9205320428,1”) in new stack
– Goto (from-trunk,9205320428,1)
== Channel ‘DAHDI/1-1’ jumping out of macro ‘from-dahdi-1’
– Executing [[email protected]:1] Set(“DAHDI/1-1”, “__FROM_DID=9205320428”) in new stack
– Executing [[email protected]:2] ExecIf(“DAHDI/1-1”, “1 ?Set(CALLERID(name)=)”) in new stack
– Executing [[email protected]:3] Set(“DAHDI/1-1”, “__CALLINGPRES_SV=allowed_not_screened”) in new stack
– Executing [[email protected]:4] Set(“DAHDI/1-1”, “CALLERPRES()=allowed_not_screened”) in new stack
– Executing [[email protected]:5] Set(“DAHDI/1-1”, “FAX_DEST=from-did-direct^4001^1”) in new stack
– Executing [[email protected]:6] Answer(“DAHDI/1-1”, “”) in new stack
– Executing [[email protected]:7] Wait(“DAHDI/1-1”, “6”) in new stack
== Manager ‘admin’ logged on from 127.0.0.1
== Manager ‘admin’ logged off from 127.0.0.1
– Executing [[email protected]:8] Goto(“DAHDI/1-1”, “app-blackhole,congestion,1”) in new stack
– Goto (app-blackhole,congestion,1)
– Executing [[email protected]:1] NoOp(“DAHDI/1-1”, “Blackhole Dest: Congestion”) in new stack
– Executing [[email protected]:2] Answer(“DAHDI/1-1”, “”) in new stack
– Executing [[email protected]:3] PlayTones(“DAHDI/1-1”, “congestion”) in new stack
– Executing [[email protected]:4] Congestion(“DAHDI/1-1”, “20”) in new stack
== Spawn extension (app-blackhole, congestion, 4) exited non-zero on ‘DAHDI/1-1’
– Hungup ‘DAHDI/1-1’