Fatal error in new FreePBX when trying to Add Extension

Add an Extension >

Please select your Device below then click Submit

Device [ Generic CHAN SIP Device ].
(or whatever another choise, just the same)



FreePBX is Unable to Continue

No Extension given

Trace Back

/var/www/html/admin/config.php:532 die_freepbx()
[0]: FreePBX is Unable to Continue
[1]: No Extension given

How to fix it??? Just installed a new system from the newest distro.

Identical issue here too…

1 Like

I installed fresh a few days ago, all worked fine. Seems like its a module update causing the issue.

Distro? Or manual install? If manual or somehing else then please give your PHP version. Also please give your freepbx version. Not to sound rude but we shouldn’t have to be pulling this information out of you.

Distro 6.12.65 - Fresh install was working fine 3 days ago. Tried fresh install on same machine today and get the error above.

Same thing here on 2 different boxes after admin/module admin upgrades tonight.

PBX Firmware: 6.12.65-20
PBX Service Pack:

Whoops, that was me. I just added some new stuff to paging, and left some debugging in. Sorry about that! Upgrade paging to and that’ll fix it.

It is. The same thing, tried doing this few days before successfully.

Distro 6.12.65-21, just downloaded an iso image and installed fresh.

OK, this worked! Thanks a lot. The problem was solved.

Thanks for this post - I am standing up a new system today and ran into this and the update got me working.

1 Like