Fatal Error after updates installation freepbx 2.7

New to Linux and Freepbx… I purchased a Xorcom IP PBX chassis with Elastix and FreePBX preinstalled.
I carried out some updates and now when I log into the web interface of Elastix and click on the PBX tab, I get the following error:

FATAL ERROR
SELECT username, password_sha1, extension_low, extension_high, deptname, sections FROM ampusers WHERE username = 'asteriskuser’
DB Error: no such field

Everything else in the Elastix platform seems to work fine.
Can anyone help me sort this out.
Cheers

Please read this thread. Read the whole thread before doing any changes:
http://www.freepbx.org/forum/freepbx/users/can-access-gui-after-upgrade-to-freepbx-2-7#comment-25795

Hi Mikael,

after doing the changes as per your link, I get the same error when trying the PBX tab in Elastix.
I went back to try your commands again, but I now get the following when I try mysql -u root -peLaStIx.2007 but, I have also tried -ppassw0rd and -padmin and
-pakuo-kfo

ERROR 1045 (28000): Access denied for user ‘root’@‘localhost’ (using password: YES)

Any help is appreciated… I am completely out of my depth here…

If you have followed the instructions given in the thread you should not have changed the root password for MySQL.

Can you do mysql -uasteriskuser -pamp109