Failed to authenticate user

After upgrade ubuntu -> dapper, asterisk => 1.2.7, freebpx => 2.2.0beta

I can’t get incomming calls from my VSP to work. Outgoing works well and 7777 from a local phone also work and a manual configuration with asterisk/dapper default configuration + my phones and registries works well but not when I try to manage asterisk by freepbx.

/var/log/asterisk/full

[code:1]
Aug 23 13:16:27 NOTICE[5755] chan_sip.c: Failed to authenticate user “013127383” sip:[email protected];tag=as293e5d43
[/code:1]

sip_additional.conf

[code:1]
register=031352950:[email protected]

[501]
username=501
type=friend
record_out=Adhoc
record_in=Adhoc
qualify=yes
port=5060
nat=yes
[email protected]
host=dynamic
dtmfmode=rfc2833
context=from-internal
canreinvite=no
callerid=Grandstream <501>

[from-rix]
type=user
qualify=yes
nat=no
insecure=very
host=cx-cust-sth01.rixtelecom.se
context=from-trunk

[rix]
username=031352950
type=peer
secret=XXXXXXX
qualify=yes
nat=no
host=cx-cust-sth01.rixtelecom.se
[/code:1]

extenstions_additional.conf

[code:1]

ALLOW_SIP_ANON = yes

[/code:1]

With this sip_additional.conf outgoing works but incomming doesn’t

sip_additional.conf

[code:1]
[from-rix]
type=user
qualify=yes
nat=no
insecure=very
host=cx-cust-sth01.rixtelecom.se
context=from-trunk

[rix]
username=031352950
type=peer
secret=XXXXXXX
qualify=yes
nat=no
host=cx-cust-sth01.rixtelecom.se
[/code:1]

With this sip_additional.conf outgoing works and incomming wont (secret in peer-definition is commented out).

[code:1]
[from-rix]
type=user
qualify=yes
nat=no
insecure=very
host=cx-cust-sth01.rixtelecom.se
context=from-trunk

[rix]
username=031352950
type=peer
;secret=XXXXXXX
qualify=yes
nat=no
host=cx-cust-sth01.rixtelecom.se
[/code:1]

Your sip_additional.conf should read something like this, after you have created the trunk named “rix”:

register => 031352950:@cx-cust-sth01.rixtelecom.se/031352950

[rix] ; Outgoing settings
type=peer
secret=
username=031352950
host=cx-cust-sth01.rixtelecom.se ; if possible replace this name with real IP address
insecure=very

Your catch-all inbound route should be able to ring up your server. If you want to direct the calls to a specific user, then create an inbound route that directs DID=031352950 to an internal extension.