Fail2ban emails banned on "localhost"

I have one stubborn PBX that keeps saying this and I don’t know why.


The notifications settings and hostname are set in Sysadmin, I dug through the Advanced Settings to make sure I’m not missing anything there, and the from string is correct. I found some other threads referencing the various files in /etc/fail2ban but I cant find anything there mentioning localhost. I restarted postfix, asterisk, the firewall, and even the entire PBX with no change. I assume this is some simple setting somewhere that got changed but I need some help here.



We usually don’t have fail2ban emails enabled, but we received an email yesterday from one of our FreePBX 14 servers, and it did include the correct hostname.

Interesting. The fail2ban emails behave differently for SIP vs SSH (correct hostname covered in the second email).


I’d recommend to not have SSH open publicly, even with fail2ban in place.

1 Like

I think that’s a result of having the responsive firewall on. The SSH service is set to only allow people listed in the networks page.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.