External numbers in ringgroup...Desparate

I’m desperately trying to make this work. I used to work last year in the 2.1.x version if I remember correctly.

I tried 4 different things:

  • Putting the external number (my cell) directly in the ringgroup number list
  • Creating a separate ringgroup just for this external number
  • Playing with the Follow-Me setting
  • Creating an custom extension with my cell phone number in it.

They ALL give me the same result… It WORKS if I call directly from an internal extension to the ringgroup or custom extension directly.

However, it DOESN’T work when an external call is directed to that ringgroup or custom extension. It will always give me the same results; my cell will ring but when I answer; there’s no audio both ways but the call stays connected.

I also worked on two Trixbox servers whit ZAP channels available but on my pure SIP system it doesn’t work. Using Freepbx 2.4.x. I tried on Trixbox 2.2.12 and 2.4.2 and also PBXInAFlash 1.1 just to see.

Any ideas?

Thanks in advance.


Sounds like the RTP is being reinvited, try adding allowexteralinvites=no into your SIP trunk definitions. This should stop the loss of sound.



Sorry, I was working on another project… maple season is coming!

First, thank you very much for taking the time to reply.

I tried your suggestion, I was very hopeful because it make perfect sens but unfortunately it doesn’t seem to work. At first I did a cut & paste of your text and I tought it was due to the small typo in it but after correcting it, the behavior didn’t change.

It must be SIP related because it works on ZAP channels but what puzzles me the most is that it used to work with previous versions of FreePBX. Several other peoples described a similar problem in the Trixbox Forums but no definitive solution was proposed.

The only common factor In all the platform and releases is FreePBX. That’s why I tried asking the question here.

Any other ideas?

thanks in advance.

there really have not been any fundamental changes in the underlying mechanism between these releases other then the more likely causes of changes in the sip settings that may have happened from putting config parameters in the sip.conf files that get rewritten by FreePBX with upgrades. If you suspect it is re-inviting try canreninvite=no on the trunk and turn on sip debug as well as trying rtp debug to see where the packets and media are flowing.

experiencing the same problem. FreePBX 2.4

I’ve been doing this scenario since AAH 1.2 and it has worked for me. I currently use PBX in a Flash 1.1 and I am running on Centos 5.0 with the latest Asterisk (1.4.18) and FreePBX (2.4) version. Might be time for clean install on your system. You might also consider what router you are using and if it is causing these issues. I have used the WRT54GS with Sveasoft firmware with no issues and am currently running a Buffalo Technologies router flashed with Tomato 1.17 firmware. No issues.

Don’t know what might be causing this for you. I also use “confirm=y” on the ring group so that when a call comes to my cell phone its asks if I want to accept the call or not. Again, I have never had this kind of issue.