External Extension not working....rings both sides ok,remote can hear me but I can not hear remote audio


I have a Asterisk/Freepbx installed at home.local extension are working fine on laptop/I-Phone etc. I can also receive and make calls on PSTN using FXO card. But the thing I am unable to correctly configure is my remote extension.

I have asked a friend to install X-Lite and he configured domain as my asterisk IP and under proxy setting used my public IP address. We both are tried to call each other, x-lite rings fine on both sides, however he can not hear me.

Can someone guide me what could be wrong.

I port forward 5060-5082, and 10000-20000 on DSL router



You need to tell us Asterisk and FreePBX versions.

Also be careful of opening your phone system to the Internet, you will be constantly hacked on to try and make phone calls as soon as the hackers see port 5060 is open.

Did you configure the SIP NAT settings in SIP settings module? If you don’t have a static IP you need to use a dynamic DNS service if you want remote extensions to be able to connect.

Hi Thanks for your response.

I am using Asterisk 1.8.11-cert1 with built in Freepbx.

  1. Yes I did config NAT setting: nat=yes, although I am on public internet but using the IP Config=static ip, with “auto config” option to get the external IP and localnetwork. I also config “nat=yes” in extensions.

the last time I tested the external extension with a x-lite on friends house, only he was able to hear my audio but I can’t.

  1. Other think I need help: How to auto call forward to more than one extension so that both extension ring simultaneously.

  2. How can I get a dynamic dynamic DNS service?



  1. dynamic dns - check your router/firewall - many of the home/home business models have access to several dynamic dns services built in. many are free if you only need one ip address. check on dyndns.com as an example. you still need to sign up, then in the router/firewall you put in the url you selected and the user id password for the account the the router will maintain the address for you.
  2. be sure that you have NAT=yes set for the extensions, not just the SIP settings.