External calls without sound

Hello everybody,

I have a problem, I configured a PBX (sangoma web interface) with PJSIP, the provider sends me 2 IPs, one to signal and one to the media, to configured the pbx I did:

  1. I configured SIP (only PJSIP)
  2. Created a trunk with the provider’s info
  3. Created routes (in and out)
  4. I was careful to include the audio codecs (about provider instructions: G729, G711a and G711u)

I have internal extensions, its works without problem, however, the external calls dont have sound, the signal reaches the phone but when you answer you don’t hear anything

Any idea?

Leave out the g729 unless you bought licenses

It’s also good practice to leave out the G.711 variant that isn’t used in your country, although the worst that happens there is a minor degradation in quality due to an unnecessary transcoding.

The signalling one is the only one that you configure into the PBX. You do not put it into the external signalling address; that is your public address, not theirs. Your address also goes into the external media address.

You might want to configure the media address into your firewall, but not into Asterisk. The provider will send this in the SDP they send to you (and if they get this wrong, it has to be deduced from the incoming RTP, not from any configuration you provide.

As noted elsewhere, the identity of the provider and (redacted) Asterisk logs make this sort of question much easier to answer.

Thanks for the answers, I reconfigurated the asterisk with my IP in the pjsip,conf, and I desactived the G729 codec, but the problem is there, no voice in the devices (in/out), in the console there isnt any error, the conection is enable but without voice…

Here is the log…


There is also no good reason why a PJSIP caller should be anonymous, given that the match/permit settings allow you cover many source addresses. As such, I would say that the trunk was misconfigured. One consequence of this is that the codecs you are offering are not those specified for the trunk. Please find the possible addresses and add them to your match/permit settings.

Also, when providing logs, please take them from the log file, as screen scrapes lack time stamps. It is also better to provide them as text, as it allows people to search them. You haven’t provided a full call, but a full call is too large to screen scrape. Sangoma run pastebin.freepbx.org, to facilitate log uploads.

If correcting match/permit doesn’t help you will probably need to capture an extended log after using the CLI command “pjsip set logger on”.

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.