External caller not getting responces

I am pretty new to Freepbx but I feel like I got most of it up and running well, but I do have one big problem. At first I thought it was several issues but I think it is just one problem.

When I dial in from my cell phone I get a ringback and the voip phone inside my network rings, but when it goes to voicemail I get only silence/static. I changed my trunk line to go to ring group, and if no one answers go to a voicemail. Now when I dial in from the cell phone I get no ringback, but all the phones that I expected ring. When voicemail comes on i only get silence/static. So then I tried the IVR, again no ringback and only silence/static. When I do this from an internal voip phone everything works fine. So it leads me to believe that it is a codec issue. But I have the default codec’s still on which I would think is fine. I am looking for some suggestions on how to troubleshoot this. Or this could be an easy fix and I just am missing something

I am using freepbs 14.0.1.rc8 (which in hind sight I should have used the stable 13).

I’m going to guess you might be seeing a codec problem. Silence is expected, static is usually an indication of a problem with the file.

The system automatically transcodes all files to whatever the codec is that your system has negotiated with the remote system. If your phone isn’t capable of using that codec, you can get this.

Try setting up all of your codecs to use Alaw or Ulaw (depending on whether you are not in the US, or in the US respectively) and see if that changes anything.

Yes this is in the US. The static is very faint very much like white noise. I went into the System Recordings and all the different codecs were selected. I tried to look everywhere I could and make sure that Alaw and Ulaw are selected. This includes on my sip trunk. Ulaw is selected first on the trunk. I am using flowroute as my sip provider. I still can make calls from the phone and it seems to work both ways, it just seems to be when the Freepbx system tries to anwser with IVR, Ring Group, and Voicemail.

I tested it again. If the call originates from the voip system the call works both ways. If the call originates outside the network neither person can hear each other.

That’s different.

That’s called “one-way audio” and is almost always a firewall issue. There are lots and lots of threads on here that deal with the strategies for dealing with one-way audio. Google, in this case, should be your best friend, right after you search the forum for “one way audio”.

Let me make sure I am getting the just of it. Since I am using a NAT I have to have the port 5060 and 10000-20000 forwarded to my server. Does the setup for the trunk not handle this? I don’t want to poke holes unless I have to.

Yep it is a firewall issue. I disabled it real quick and I was able to get the calls. I will poke the holes now. Ugh I hate making holes.