External behind extension calls do not work

So, this is driving me insane, and i am out of Google results. I am sure one of you know the solution in moments.

We have a Freepbx 16 running on 3 outs with some 20 attached phones. This is a simple set up. nothing very fancy. We do now sit behind a nat but i have routed the ports and changed config to yes. We do have two IRVs one for open hours, and another for after hours. The after hours IRV has an option to talk to an on call specialist. This had run as a virtual extension, Follow me, to the external number. however. last night this stopped working.
I have.
added a local extension to the follow me, this worked, however skipped over the external number
made a normal extension, logged into it from my desk phone, the follow me also ignored the external number.
When i set up a follow me to go ring, local, external, local. it will ring all the local, in order, but skip over the external.
I made an extension and set up misc destination as the external number, this will come back with lines are busy or call refused.

I can make calls out, in, move them to extensions, and follow me to extensions.

What am i missing?! . Thank you

Immediate solution -

ashcortech
but have you tried routing directly to the misc destination without going through an extension’s FMFM?

Do you have a # at the end of the external number in the FMFM list? External numbers require a # at the end of the number in order to route them outside the system.

Yes i have.

Have you tried using a misc destination?

“I made an extension and set up misc destination as the external number, this will come back with lines are busy or call refused.”

Yes

but have you tried routing directly to the misc destination without going through an extension’s FMFM?

Oh. no. that i have not tried.
Hold on.

ashcortech that worked. thank you.

1 Like

This does solve my immediate issue.
however, does not solve the extension issue. any ideas? can i re-install the module without settings loss? could it be a messed up setting?

I believe you should be able to re-install without issue but I would make sure you have a backup of the system OR do a bulk export of the extensions beforehand so you can re-import them.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.