Extensions that are part of a queue not able to get calls after transfer

We are having an odd new problem after updating FreePBX back around October 2017. We have a consumer call center with about 8 extensions in a queue. If a call comes into the queue, and the agent answers the call, then transfers the call to another agent, the agent that originally took the call will not get any more calls from the queue until the agent that the call was transferred to hangs up.

So, if the other agent receiving the transfer stays on the phone for 30 minutes, the agent that originally answered just has to sit there for 30 minutes waiting, and can’t answer any new calls. Everything worked before the update?

Could this be some new bug?

Bruce

Asterisk bug which was fixed months ago. I assume you’re on Asterisk 13, make sure it’s up to date.

Lorne,

We are apparently on Asterisk 11 (11.25.2). If I run the update through System Admin, will that update Asterisk?

Time to migrate to 13:

https://wiki.freepbx.org/display/PPS/Changing+Major+Asterisk+Versions+on+the+Fly

“Time” being a little flexible. While the procedure outlined in the “Changing Majors” document is good, it can’t anticipate every configuration option and can’t foresee what people might have installed outside the typical Asterisk stuff. Wait until the weekend to make your image backup then start and go slow. If everything goes well, you’ll be online with a fully working system in a few hours. If not, you have your image backup to drop back to.

Linked wiki page is for upgrading to Asterisk 13 (not FreePBX), which takes 3 minutes at most and can be undone with the same procedure.

Never bill for less than two hours…
:slight_smile:

1 Like

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.