Extensions not showing up in paid endpoint manager

Hello Everyone!

Im using FreePBX and have an odd problem. I had a phone “Cisco 7960” that was not showing as registered. So I bring up freepbx gui and notice that the phone is listed in the endpoint manager but does not have an IP and ping associated with it, huh thats odd. The config file in there in the TFTPboot folder but it will not register. So I remove the entry in the endpoint manager, factory reset the phone and go to add it back in. Except the extension does not show up in endpoint manager anymore when I create a new extension map. Ok thats odd, so I go into extensions and it is listed. Delete it from there and recreate it, everything looks good except it is still not listed as an option in the endpoint manager.

I do have the paid endpoint manager. Any ideas?

Have you tried to install adobe reader :slight_smile:

I’m not quite sure what the issue is here… The phone isn’t registering with asterisk even though you’ve created an entry in EPM for it?

jarvisswope: What does acrobat reader have to do with this?

Do not mind Jarvis he is just giving me crap :slight_smile:

So if I create an extension and then go into the EPM to assign that extension to the phone the extension does not show up. Lets say its extension 300. It does not show up as an extension to chose in the EPM so I can not assign it. Now if I manually create the phones cfg-mac file in the TFTP folder it will pool it and register the phone. If I create extension 3001 or 301 or anything it will work fine and show up in the EPM as an extension I can assign to the phone

Use the “other” tab in extension settings and enter the MAC address of the phone there, template etc

Inside joke :slight_smile:

As previously mentioned, you need to assign a MAC address to the extrension (along with the phone type, template, etc). I usually create the extensions, then head in to the EPM, have it scan for phones, then assign the phones it finds to extensions.

Of course you still have to create the templates and preferably assign Firnware slots. After that’s done, check in /TFTPBOOT to make sure that the config file was created. If so, make sure your phone knows where to get the config file (Provisioning server), and you should be good.

On the TFTP server have you configured option 66 to point to the pbx?
Or in the phone itself is your config server entry correct (pbx ip)?
Is the IP Phone getting an IP address (Advanced IP Scanner or DHCP server)?

Unless the phone has a valid IP and can reach the pbx over the network, EPM will not help you. If you manually enter the MAC, brand and model under the extension settings you may not see it in a network scan with EPM.

Sip Sip