Extensions just won't register, please help troubleshoot


(Electriclove) #1

I have 3 separate instances of FreePBX, all 3 running different versions, one a VM, one a PC, and one is RasPBX. All 3 of them work with my SIP trunk and I can set anything up, but none of them seem to connect to any devices.

I have a SIP Phone, an ATA adapter, and numerous soft phones. None will connect to any server, and I don’t know why. It all worked in the past.

I have a DDWRT router behind a pfSense firewall. I assume since the issue persists with all servers and phones that it may be the network environment.

I made the extensions pretty simple, like 111 for every field including the password. I’ve tried both ChanSIP and pjSIP.

SIP systems are new for me. I don’t know how to troubleshoot this sort of thing. I dearly appreciate any help you are willing to offer.


#2

Start with a simple device. For SIP phones, Yealink, Grandstream, Cisco SPA series and Polycom VVX series are fine. Enterprise Cisco and older Polycom are difficult to configure and not suitable for a beginner.

For ATAs, Sipura/Linksys/Cisco are fine, as are Grandstream and Obihai.

For softphones, Zoiper, Linphone, MicroSIP and PhonerLite under Windows, MacOS or Linux are fine. Don’t use anything on Android or iOS.

Use a simple connection. The device should be on the same LAN subnet as the PBX, so traffic does not pass through pfSense or DDWRT.

For the PBX on a VM, make sure the VM is using bridged networking.

Does the device register? If so, what goes wrong when you try to call? If no, does anything appear in the Asterisk log when it attempts to register? If so, post that. If not, run sngrep and see whether anything shows on registration attempts. If yes, it’s a FreePBX firewall issue; disable that for testing. If not, capture traffic at the device (easiest on a softphone) and see whether the registration attempts are being sent to the correct IP address and port.

If you still have trouble, post details about the device you are using, its settings, etc.


(Electriclove) #3

Thanks for the reply. I nuked the whole system and rebuilt from zero. Everything works great now. Sometimes one just must do that.