Extensions error on delete when there is no associated user

When deleting an extension from the /admin/config.php?display=extensions page using the garbage can icon or by multi-selecting and using the red “Delete” button, the following error message is displayed:

Trying to access array offset on value of type bool

This only occurs for extensions that don’t have an associated user.

If I enter the edit screen for an extension (e.g. /admin/config.php?display=extensions&extdisplay=2107), the same extension will delete without an error.

Any ideas? Thanks in advance!

What version of FreePBX? If you are on 15 or 16 and your PBX is up to date, please report this as a bug: issues.freepbx.org

Thanks for the reply. I am working on version and all available updates are applied. I’ll post this as an issue.

Remove the Follow Me module if you are installing a version other than: 16.0.22
fwconsole ma remove findmefollow
fwconsole reload
fwconsole ma downloadinstall findmefollow --tag=16.0.22
fwconsole restart
*I tried and the problem was solved. The version of FreePBX I used was
Even the FreePBX “Loading” take a long time after clicking “Apply” has been solved.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.