Extensions can only receive single call

It used to work.

FreePBX 2.9.0.12 on 192.168.1.253

My phones are Aastra 9143i’s, configured with Endpoint Manager.

When a phone is in a call, it cannot receive a second call. If, for example, I use extension 201 to call 202 and leave those off-hook, and then use 203 to also try calling 202 (or 201), I get a busy tone.

Previously, Line #2 would ring on 202 and 202 could put the current call (Line #1) on hold, then pickup Line #2.

When I watch the Asterisk console while this is happening, I observe:

-- Executing [[email protected]:42] Dial("SIP/203-00000062", "SIP/202,,trwWI"

) in new stack
== Using SIP RTP TOS bits 184
== Using SIP RTP CoS mark 5
– Called SIP/202
– Connected line update to SIP/203-00000062 prevented.
– Got SIP response 486 “Busy Here” back from 192.168.1.19:5060
– SIP/202-00000063 is busy
== Everyone is busy/congested at this time (1:1/0/0)

I have attempted some self-help by checking that the “Call Waiting” module is installed and enabled. The “Call Waiting” is enabled for the extension (for all extensions, actually). If I look at the “Extension Settings” there is a checkmark for CW for each phone.

All my software is up-to-date. Module admin is showing everything up to date, and the next jump would be going to 2.10, which I haven’t done.

Any ideas on how to debug this?

Okay, I may have figured something out.

In comparing the configs of the phones that DID work vs. the phones that DID NOT, I noticed that the status screen of the phones that DID work showed registration with the server on all three lines. The phones that did NOT work only showed registration on the first line. Line 2 and line 3 showed a failure.

Some time ago I had been having some problems w/ Callcentric (during their attack) and was playing with the SIP settings before I realized the problem wasn’t on my end. So recently when I updated the phones configurations and rebooted them, the changes I had made screwed-up the local phones, but the remote phones settings were okay.

So now the local phones are showing three registrations and a test to make one of the phones rings with two incoming calls did not result in a busy. Of course, I cannot verify it is working until tomorrow, but I have high hopes.

It doesn’t seem like anyone had much of an idea for where I should start, so I thought I’d post-back that I made some progress.

The phones at work (extensions 200…204) are exhibiting this problem.

The remote phones at home (205…206) are not. They are working fine. I think I should be commended for having exactly the opposite problem most people seem to experience (most people can’t get remote phones going).

If, for example, I use my cell # to call the trunk being served by the Asterisk box, and while it is ringing use home phone #205 to try to call work extension #202, I get a busy signal.

If, on the other hand, I use my cell # to call the same trunk, and while it is ringing use home phone #205 to call home phone #206, it rings and Line #2 lights up on the phone.

For a second, I had thought the phones were the culprit, that the “Call Waiting” feature on the phones may have somehow got disabled. But it wouldn’t make sense for just the phones at work to have that get switched. And when I looked at the server.cfg and local.cfg on the phones, the phones at work seem to match the remote phones (at home) as closely as they could.

Anyway, if anyone has any ideas feel free to jump in. :slight_smile: