extensions_additional.conf never updated

I have a client using version 2.2.0 and recently when updating extensions and such through the UI and pressing the reload red bar has stopped updating the configuration files. I’ve checked the database and the data is saved there but it just isn’t written to the configuration files.

I have been debugging the PHP code I am seeing that the admin/extensions.class.php generateConf() is not being call on the customer’s system where as it does on mine. What is perplexing to me is that I am unable to determine where in the code that the generateConf function is invoked. I attempted to use the php debug_backtrace() function to see the call stack but that isn’t working either.

Can anybody provide me some clues?

Thanks,

John

Running /var/lib/asterisk/bin/retrieve_conf --debug will usually give you some good clues as to what is happening.

I would recommend upgrading to at least 2.2.3 though. There are a fair number of bugs in 2.2.0 that have been fixed, so it is probably worthwhile to upgrade since you’re having issues anyways. It’s hard for other people to help you when you’re on an outdated version, and it’s even worse if it turns out it’s a bug that doesn’t exist anymore.


Greg MacLellan - Core FreePBX Developer
http//freepbx.org - irc.freenode.net #freepbx

Thanks Greg -

That command led me to the problem which happened to be that the client changed the amp password in one spot but it is defined in two places and they only changed it in one.

Is there any reason that the password is defined in both etc/ampportal as AMPMGRPASS and in etc/asterisk/manager.conf as secret? Wouldn’t it make more sense to just reference ampportal.conf ?

Best Regards,

John

I ran in to the same issue a few weeks ago and what fixed it for me was to disable the “Blacklist Module”. After I did that the *.conf files started to be written again.