Extension Voicemail Options are not Saving

I have several extensions that I am attempting to send voicemail emails to.
When I enter the user’s email address and submit it, the system reverts the field back to their first name.
Also the options for Email Attachment, Play CID, Play Envelope, and Delete Voicemail revert to nothing selected.

If I hit submit again with their first name in the email address, then it puts the first name in the Pager Email Address field.

If I hit submit again, it puts their first name in the VM Options field.
This is a new Sangoma server, just purchased 2 weeks ago.

Anyone else seen this behavior?

Personally have not. Have you tried setting directly in Settings>Voicemail Admin and received the same results or on the Extension only?

Have you tried reinstalling the voicemail module?

I tried Settings -> Voicemail Admin -> User and got the same results.
Then tried Settings -> Voicemail -> User -> Account Advanced Settings and got it to save somewhat correctly.
At this point I believe Voicemail is working.

No I have not tried reloading the Voicemail Module. If I uninstall it, does it wipe out settings for the users which will have to be reentered after the module is reinstalled?

I can’t say 100% if it will wipe the settings. I know in the past I’ve done it and it was fine but I’m not sure about now due to changes since.

I’m having the exact same issue, where you able to solve this?

I solved this.

The system stores the values in the fields from the voicemail tab of the Extension into the voicemail.conf file under /etc/asterisk this file accepts the format of


(from: http://www.asteriskdocs.org/en/2nd_Edition/asterisk-book-html-chunk/asterisk-APP-D-SECT-41.html )

so that a valid entry looks like:

1234 => 9999,Joe Smith,[email protected],attach=no|saycid=no|envelope=no|delete=no

where the name comes from the “Display Name” field on the General tab. The issue I was having was that the display names in my setup had the format of “last_name, first_name” and the comma was getting picked up so the format of the voicemail.conf file ended up as

1234 => 9999,Smith, Joe,[email protected],

Just noticed that I was having the same issue

I’ll issue a bug report about the comma causing the problems.