Extension to extension calls drop out after 30 seconds

I updated yesterday to Freepbx and since then internal extension to extension calls drop out after 30 seconds. I have changed nothing else and did not have this problem before.
All extensions are on the same internal network and inbound and outbound calls to outside numbers works fine.
All extensions register OK and can make calls.
Any suggestions please.

Ralph Graham

In Asterisk SIP Settings, confirm that External Address and Local Networks are correctly set. If you change these, restart (not just reload) Asterisk.

If that’s not it, at the Asterisk command prompt, type
pjsip set logger on
sip set debug on
according to extension type, make a failing test call, paste the Asterisk log for the call at pastebin.freepbx.org and post the link here.

Sorry to be ignorant, where do I find the Asterisk SIP settings you refer to and what would external address and local networks be if correctly set?
In addition if they have worked for the last 3 years how would they have changed?

Thanks for reply

GUI > Settings > Asterisk SIP Settings

You will see a Detect Network Settings button below the External Address field. Click it. This should autodetect and populate the External Address and Internal Networks fields for you, then Submit, and restart services via the SSH/Console:

fwconsole restart

On that same Asterisk SIP Settings page, try setting Strict RTP to NO if the addition of the addresses above does not resolve the issue.

Thank you The WEbMachine without altering Strict RTP your other suggestion has worked.
Problem solved.
Like others I have this pjsip offline extension I know nothing about. It is listed as 7d4e9a4e-689c-4cc6-ab86-2435c68896b6. Any idea what this is and should I worry to remove it, if so how?

Thanks for help

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.