Extension Routing isn't being respected, calls always go through first route


#1

Hey there,

I’m using the Extension Routing-Package to restrict the Outbound routes a specific extension can use.
However, since lately, no matter from which extension a call is being made, it always uses the first available outbound route, without respecting the extension routing.

This, in the end, leads to all outbound calls coming from the same outbound route, which really isn’t good.

Is this a known issue, or did I probably configure something wrong? I’ve already tried reinstalling the package to make sure it wasn’t just broken, however this didn’t help.

I’m on PBX version 15.0.16.75, System version 12.7.8-2008-1.sng7 and extension routes version 15.0.5 (licensed).

Here’s a full log of an outbound call which should’ve been routed through a route ending with “490”, it used the route ending with “075” (which is the top route in the outbound routes view). I’ve censored most parts of the phone numbers, but always left the last three ciffers so it’d be possible to identify them.
https://files.cheaperhillsnetwork.de/files/extension-routes-debug/full-1.log


#2

I have, in the meantime, tried out every other available rollback-version of the extension routes module; 15.0.4, 15.0.3 and 13.0.10.7. Didn’t help.


#3

Solved with the friendly help of Rob Thomas. I discovered this issue first occured after a restore-process from a backup. He then suggested to reinstall the module through the CLI “fwconsole ma uninstall extensionroutes && fwconsole ma install extensionroutes”, which made sure it’s database tables exist. After that, the GUI-Settings of the module were defaulted back to an allow all-state. After configuring the module again, everything worked fine!