Extension routes broken after update to FreePBX15

After upgrade my system to FreePBX15 the extension routes module is broken. First it was listed as “Upgrade to 15.0.1 and Enable” and when I tried that it gave me some strange SQLError about a duplicate key. So I tried to uninstall/reinstall it. Unfortunately the uninstallation only worked partially and now when I try to reinstall it I get the error “SQLSTATE[42S02]: Base table or view not found: 1146 Table ‘asterisk.extensionroutes’ doesn’t existIninitalization of extensionroutes multi-insert failed::”. Any ideas on how to fix this issue I badly need “extension routes” to work. Of course as the upgrade has broken it I obsiouly don’t want to buy a paid subscription.

I already tried force installing it through fwconsole with same error.

After looking more closely into the error, I came across this (see picture below) in the content of a extensionroutes php file.

I’m no expert on php but very obviously this doesn’t look like a proper php file, it looks like some garbage. But even deleting the module and re-downloading it fixes this issue.

I tried “fwconsole ma delete extensionroutes” and “fwconsole ma downloadinstall extensionroutes” but the result is the same. So my question is now, is the download package of extensionroutes defective?

Not defective, Extension Routes is a commercial module and the code is obfuscated.

I’m not sure what’s going on here, but as an owner of a commercial module, you should be able to open a free support ticket.

1 Like

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.