Extension restriction problem

Hi , i am using Freepbx 2.4.1.0 to apply predefined Custom Context to individual extensions. 2 of them however, somehow ignore the context and get the context that stands for dialing local numbers only.(ExtensionOnly).Here is a sample of zapata_additional.conf, where the context is what it should be.

;;;;;;[672]
signalling=fxo_ks
record_out=Adhoc
record_in=Adhoc
[email protected]
immediate=no
echotraining=800
echocancelwhenbridged=no
echocancel=yes
dial=ZAP/236
context=from-internal
callprogress=no
callerid=device <672>
busydetect=no
busycount=7
accountcode=
channel=>236

However the user at the specific extension can’t dial anything except local calls.Here is a samle of the log file where the context for this extension is ExtensionOnly.

[Dec 3 09:13:49] VERBOSE[29579] logger.c: – Executing [[email protected]:1] Goto(“Zap/236-1”, “app-blackhole|hangup|1”) in new stack
[Dec 3 09:13:49] VERBOSE[29579] logger.c: – Goto (app-blackhole,hangup,1)
[Dec 3 09:13:49] VERBOSE[29579] logger.c: – Executing [[email protected]:1] NoOp(“Zap/236-1”, “Blackhole Dest: Hangup”) in new stack
[Dec 3 09:13:49] VERBOSE[29579] logger.c: – Executing [[email protected]:2] Hangup(“Zap/236-1”, “”) in new stack
[Dec 3 09:13:49] VERBOSE[29579] logger.c: == Spawn extension (app-blackhole, hangup, 2) exited non-zero on ‘Zap/236-1’
[Dec 3 09:13:49] VERBOSE[29579] logger.c: – Hungup ‘Zap/236-1’

i Then deleted the extension and added the same one again , and i got the same results .

Can anyone help me?
thanks

What are you trying to accomplish?

Hi , thanks for your response
There are 6 defined custom contexts for outbound calls in Freepbx that i assign to individual extensions
I want to be able to assign different contexts to all of the extensions.
However 2 of the extensions , ignore the custom context i assign to them.No matter which context i assign to these 2 extensions , they allways use ExtensionOnly context (that stands for making only local calls) when dialing out. Previously i posted the settings i got in the config file and in the log file for one of these two extensions.(lokal 672, Zap/236-1)
Thanks again :wink:

The PBX uses more than 150 extensions on zaptel channels, and 20 sip extensions.
There is one default trunk line - PRI.

In order to restrict customers for getting outside trunks, we have installed and are using the custom context module for freepbx.

We have created a couple of different custom contexts that have different restrictions like::

Allow ALL - allow all outbound calls
NationalMobile - allow local, national and mobile calls
National No Mobile - Allow ony local and national calls without support for mobile calls

extension only - allow only calls to extensions in the PBX.

These all seem to function without any problem on the old extensions we have defined.

The problem is that we added new 16 ports (zap channels) to the PBX system, and added new extensions to those ports.

What ever setting we add to the extensions for the custom context the extension always works as it is in the ExtensionOnly context.

The above example is for a definition of one of the extensions in the zapata_additional.conf, and a part of the log from asterisk when that extension tries to make an outside call - a call to the trunk line.

Im still not sure what your trying to do (perhaps cause I didnt read your post well enough) but are any of these links helpful?