Extension not register over WAN

My FreePBX (14.0.11) has both LAN and WAN networks. My SIP trunk provider use static IP to connect. I have SIP trunk service over the WAN IP. When I tried to register an extension from the outside (offsite) using the WAN IP, the extension failed to register. The phone registers fine from the LAN. What’s missing?

Do you have things setup to allow remote access to the PBX? Proper firewall/NAT rules, all that?

Thank you for your reply. I’ve been troubleshooting the issue with my trunk provider. I’ve made some headway but it’s still not operational. 1st, let me clarify, the server WAN is directly connected to the Internet. So, no need for NAT rules on the server side. 2nd, I’ve enabled "CHAN_SIP protocol on the server to allow the remote extension to register. 3rd, I’ve changed the NAT Mode for the extension from No (default) to Yes. The extension is now registered on the server. I can ring the extension now. But that is all I can do. As soon as the extension is picked, the server ends the call. I suspect the issue has to do with remote extension. How do I NAT the firewall with 2 remote extensions?

A troubleshooting step that would help is to include an extract of the /var/log/asterisk/full log when the call is made and fails.

A second helpful piece would be a SIP DEBUG on the extension so we can see what addresses and ports the phone is trying to use.

I captured the following message with the command “asterish -vvr”
Dialing out from the extension (x10)… to my cell phone

== Using SIP RTP TOS bits 184
== Using SIP RTP CoS mark 5
== Spawn extension (macro-dialout-trunk, s, 24) exited non-zero on ‘SIP/x10-0000003d’ in macro ‘dialout-trunk’
== Spawn extension (from-internal, 416xxxxxxx, 7) exited non-zero on ‘SIP/x10-0000003d’
== Spawn extension (macro-hangupcall, s, 7) exited non-zero on ‘SIP/x10-0000003d’ in macro ‘hangupcall’
== Spawn extension (from-internal, h, 1) exited non-zero on ‘SIP/x10-0000003d’
== Using SIP RTP TOS bits 184
== Using SIP RTP CoS mark 5
== Using SIP RTP TOS bits 184
== Using SIP RTP CoS mark 5
== Spawn extension (from-trunk, 416xxxxxxx, 1) exited non-zero on ‘SIP/AllOutBound-0000003f’
[2019-05-31 17:34:46] WARNING[12319]: chan_sip.c:4068 retrans_pkt: Retransmission timeout reached on transmission [email protected] for seqno 2 (Critical Response) – See https://wiki.asterisk.org/wiki/display/AST/SIP+Retransmissions
Packet timed out after 6400ms with no response
[2019-05-31 17:34:46] WARNING[12319]: chan_sip.c:4092 retrans_pkt: Hanging up call [email protected] - no reply to our critical packet (see https://wiki.asterisk.org/wiki/display/AST/SIP+Retransmissions).
== Spawn extension (macro-dialout-trunk, s, 32) exited non-zero on ‘SIP/x10-0000003e’ in macro ‘dialout-trunk’
== Spawn extension (from-internal, 416xxxxxx9, 7) exited non-zero on ‘SIP/x10-0000003e’
== Spawn extension (macro-hangupcall, s, 7) exited non-zero on ‘SIP/x10-0000003e’ in macro ‘hangupcall’
== Spawn extension (from-internal, h, 1) exited non-zero on ‘SIP/x10-0000003e’
== Spawn extension (from-internal, h, 1) exited non-zero on ‘SIP/x10-0000003e’

I really don’t what the message is saying. The thing is when I pick up the call on my cell phone the server hangs up the call. Can anyone explain what is going on with server?

From the asterisk CLI

sip set debug ip 192.168.xx.xx

(FYI It is unnecessary to obfuscate private ip addresses)

This, IME, reflects a NAT Settings problem.

1 Like

Thank for the suggestion. I have to cleanup my router rules be before I can test out your suggestion.

I’d turn off NAT and use a STUN server for call setup, make sure ports and server ip can be seen by pinging it.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.