Extension not found in context 'from-internal'

[2013-10-01 08:09:17] NOTICE[2840] chan_sip.c: Call from '23680957' (172.20.11.40:53647) to extension '1000' rejected because extension not found in context 'from-internal'.

I get this error when trying to call between the two phones on my test install of freepbx. I searched around and poked around but haven’t been able to fix this.

I have a soft phone and a hard phone to test with. I am trying to call between them.

Both phones are registered. The accounts on the phones are registered.

I found the [from-internal] context in extensions.conf. It says I’m not supposed to edit that, but I did anyways:

[from-internal]
exten => 1000,1,Answer()
exten => 1001,2,Answer()

include => from-internal-noxfer
include => from-internal-xfer
include => bad-number ; auto-generated

Same error.

Well do not do that, whatever changes you make will be overwritten anyways.

Try running “sip show peer 1000” at the asterisk CLI followed by “dialplan show [email protected]” and provide the output for both.

localhost*CLI> sip show peer 1000
  • Name : 1000
    Description :
    Secret :
    MD5Secret :
    Remote Secret:
    Context : from-internal
    Subscr.Cont. :
    Language :
    AMA flags : Unknown
    Transfer mode: open
    CallingPres : Presentation Allowed, Not Screened
    Callgroup :
    Pickupgroup :
    MOH Suggest :
    Mailbox : [email protected]
    VM Extension : *97
    LastMsgsSent : 0/0
    Call limit : 2147483647
    Max forwards : 0
    Dynamic : Yes
    Callerid : “1000” <1000>
    MaxCallBR : 384 kbps
    Expire : 1947
    Insecure : no
    Force rport : No
    ACL : Yes
    DirectMedACL : No
    T.38 support : No
    T.38 EC mode : Unknown
    T.38 MaxDtgrm: -1
    DirectMedia : No
    PromiscRedir : No
    User=Phone : No
    Video Support: No
    Text Support : No
    Ign SDP ver : No
    Trust RPID : Yes
    Send RPID : No
    Subscriptions: Yes
    Overlap dial : Yes
    DTMFmode : rfc2833
    Timer T1 : 500
    Timer B : 32000
    ToHost :
    Addr->IP : 172.20.11.96:5062
    Defaddr->IP : (null)
    Prim.Transp. : UDP
    Allowed.Trsp : UDP
    Def. Username: 43209716
    SIP Options : (none)
    Codecs : (gsm|ulaw|alaw)
    Codec Order : (ulaw:20,alaw:20,gsm:20)
    Auto-Framing : No
    Status : OK (23 ms)
    Useragent : Yealink SIP-T28P 2.61.0.80
    Reg. Contact : sip:[email protected]:5062
    Qualify Freq : 60000 ms
    Sess-Timers : Accept
    Sess-Refresh : uas
    Sess-Expires : 1800 secs
    Min-Sess : 90 secs
    RTP Engine : asterisk
    Parkinglot :
    Use Reason : No
    Encryption : No

localhost*CLI>

localhost*CLI> dialplan show [email protected] There is no existence of 'from-internal' context Command 'dialplan show [email protected]' failed. localhost*CLI>

My guess is that extensions.conf is not being read/loaded by asterisk…permission ok?

run ‘dialplan reload’ followed by ‘dialplan show’. There will likely not be much there at all if its a permissions issue.

So this is interesting…

localhost*CLI> dialplan reload No such command 'dialplan reload' (type 'core show help dialplan reload' for other possible commands) localhost*CLI>

help

oh but this one works:

localhost*CLI> dialplan show [ Context 'app_queue_gosub_virtual_context' created by 'app_queue' ] 's' => 1. NoOp() [app_queue]

[ Context ‘app_dial_gosub_virtual_context’ created by ‘app_dial’ ]
‘s’ => 1. NoOp() [app_dial]

[ Context ‘parkedcalls’ created by ‘features’ ]
‘70’ => 1. Park() [features]

-= 3 extensions (3 priorities) in 3 contexts. =-
localhost*CLI>

permissions on /etc/asterisk/extensions.conf:

lrwxrwxrwx 1 asterisk asterisk 52 Sep 25 14:41 extensions.conf -> /var/www/html/admin/modules/core/etc/extensions.conf

and on /var/www/html/admin/modules/core/etc/extensions.conf:

-rw-rw-r-- 1 asterisk asterisk 23615 Sep 30 09:58 extensions.conf

permissions on /etc/asterisk
permissions on /etc/asterisk/extensions.conf:

lrwxrwxrwx 1 asterisk asterisk 52 Sep 25 14:41 extensions.conf -> /var/www/html/admin/modules/core/etc/extensions.conf

and on /var/www/html/admin/modules/core/etc/extensions.conf:

-rw-rw-r-- 1 asterisk asterisk 23615 Sep 30 09:58 extensions.conf

lamo mac boy

What version Asterisk and FreePBX? Tell us about how it was installed. If a distro which one? If installed by hand what OS?

FreePBX 3.211.63
Asterisk 10.12.3-digiumphones

I did reinstall asterisk after installing freepbx. I had to get the version of asterisk that works with digium phones. But then I ended up not using a digium phone. So I could actually reinstall the whole system so I am “stock” again. Should I?

Yes, I’d suggest installing the freepbx distro, Asterisk 11. That will support the Dphones.

Just reinstalled FreePBX vanilla. It works now. I recreated my extensions and my two phones (which were already setup with those extensions) could immediately call each other.

Thanks.