extension_custom.conf script not working, Please help!

Hi everyone,

Sorry to bother everyone, since this might be easy to fix, but i yet have found the problem. I wrote a custom dialing plan and the first part works. I have been letterly loosing sleep over this for the last week or so to make it work. Please Help!

Here’s what i have done so far. Please correct me if I have done or missed something. This dial-plan is somewhat critical for the service i offer. so any changes advise or placement of the scrip on my system would be a great hand

Oh yeah I should say I am using elastix 2.0.0-42 with freepbx, centos 5.X.X

All ready in system.

custom exten: 2200
custom dist: 2200,1,dial

The following was/is placed in the – extensions_custom.conf file – It is the very first context listed in the conf file. The script below is exactly what is typed and in the extensions_custom.conf file.
excluding any personal information it’s been changed and anything in the ***

exten => 2200,1,Dial(SIP/2200/17095551234,M(Send_Digits)tr);
sometimes works, get your call cannot be completed as dialed most of time

[macro-Send_Digits] ***nothing happens at all here. even tried with/without “macro-” ***
exten => s,1,Wait(1);
exten => s,n,SendDMTF(7);
exten => s,n,Wait(5);
exten => s,n,SendDMTF(100);
exten => s,n,Wait(2);
exten => s,n,SendDMTF(1234);

I have tried with and without the following placed above [customroute1] with no results.

include => macro-Send_Digits
include => customroute1

It goes without saying I need it to go from [customroute1] to the next steps in [macro-Send_Digits] automatically. I do not want the customer(s) to know anything until they receive a prompt from the other end.


Test to go to macro directly first if it works:
exten => 2200, 1,macro(Send_Digits)