Extension calling an extension; calling the wrong number

We currently use FreePBX to handle on call. Currently for daytime hours we have the pbx call our ring group, which includes our office phones. If the daytime hours are not met, it dials the on call person’s blackberry extension. This extension is modified via a script.

To handle holidays, I’ve added an extension (802) to our daytime hours ring group. This extension is set to dial the blackberry of the oncall person. This is also updated by the script. Originally I manually entered my extension into the 802 settings. I tested calling the on call number, and my blackberry rung as well as our phones. So I manually entered the extension for the oncall person into 802 (extension 403 for reference).

I updated the script to modify this entry as well. And I can see that this week it has my extension in there as expected. But when I on call number, it still calls the 403 extension number.

When the script runs the retrieve_conf file and does amportal restart, I figured the /etc/asterisk/ files were being updated. But I couldn’t find any of our extensions in extensions.conf. Im wondering if there’s another place I should be looking, or is the database used for the calling information? Or is there something else wrong here?

Ive found the problem, just not sure how to fix it. An old colleague told me to run: asterisk -vvvr to see lots of verbose output. So I tested calling our oncall number and could see the 403 extension referenced, when it should be 405, as it shows on the webpage.

i had entered 403 manually, so I went to the freepbx admin page. I opened the 802 extension page and pressed submit. I press the button uptop to update freepbx engine with the changes. Called the on call #, and the verbose logs showed 405 being dialed.

So my question is how can I “press submit” from command line? Is it something like running /var/lib/asterisk/bin/retrieve_conf? or something else?

So my question is how can I "press submit" from command line?

Try the command:
/var/lib/asterisk/bin/module_admin reload
It is handy to know. Run the above command with --help option to get a list of other stuff it does.

I added that to the script, told it to update to my extension. I ran the script, it updated the entries. But when I called, it rang the number I had entered yesterday.

Here’s what my script does after updating the database:

/var/lib/asterisk/bin/module_admin reload;
system( “amportal restart > /dev/null 2>&1” );