EXP100 stop working

I continually have issues with these EXP 100 sidecars and the S700. It could be they have issues with all phones, but it seems like monthly at least one side car will stop working for someone. Reboot, does not fix the problem but often a complete power down and up will correct the issue.

This weekend another stopped working and nothing I’ve tried will bring it up.

Is anyone else having these issues with EXP100?

Thank you,


Yes, I have had had quite a few issues with the EXP 100 module; however not on the S700, rather the S500.

I have been working with support on the issues. In my case the model reports it cant connect to the phone, and we have audio issues on the phones every 10 seconds.

My support call has some good progress; I would suggest you log a call, and maybe reference ticket 798661 - just in case they are a similar thing.


Last night I upgraded a S700 with EXP100 to the newest firmware. Now the EXP 100 does not show as connected. I’ve tried rebooting, resetting to Factor Default but the EXP 100 still shows as not connected.

It was all working before the upgrade and no cables were touched.

Any suggestions on how I could get this working again?

Sounds like a ticket might be in order. I’d start on the “support” side since it is a Sangoma product.

Hi Jason

I haven’t heard anything further with regard to my support case I referenced above. Release notes refer to changes for the EXP100 on the S700 phone - which doesn’t apply to me, so maybe it’s still coming?


I’ve actually had several Support tickets open on these phones and have been very disappointed with them. Received a call this morning from a customer saying a phone side car is not working. All lights are green and there is no indication on the BLF when another extension is on the phone. Pressing BLF buttons on the EXP100 also has no effect. Unplug the power from the EXP100 and back in, then it’s working again.

Customer is very unhappy and says they will be walking around to all phones checking to ensure the sidecars are working. It’s never a good thing for your customer to have to continually ensure their phones are working correctly.

Hi Jason

What other phones have you looked at? I’m looking at swapping out the phones I have EXP modules on.

They are causing us too much pain, and I don’t really have a clear direction forward.

I would like to go Polycom, but lack of FreePBX support has eliminated them, and have looked at Digium, which the hardware also seems rock solid, but appears to be no support in PBXAct for them, and doesn’t look like the lasted versions of the hardware are supported anywhere.

I totally understand why Sangoma want people using there hardware, and have all but discontinued support for other devices (haven’t, I know, but focus is on Sangoma phones) but surely when you don’t have a rock solid solution available, you need to continue to support other peoples hardware?

For us, we are looking to see if we can remove the requirement for Phone Apps from our users, and manually provision phones for EXP100 users, as a temporary solution, while we readdress the future…

Too many issues, without timely resolution unfortunately.


What is your current issue you are seeing? I thought this was addressed in the latest firmware the issue some users saw with expansion modules.


PM me your ticket and I will have our Director of Support reach out to you.

We have many more S700 phones deployed on other customer networks without the problems I’m seeing on the PBXAct appliance. Difference is, they are all using Freepbx.

It has nothing to do with FreePBX versus PBXact. Hints are all part of astersik core. Do you have different asterisk versions maybe.

This is the only PBXact system we have, Current Asterisk Version: 13.19.1

Checking other Freepbx servers, they are Current Asterisk Version: 13.17.1

The code that handles all of this in FreePBX is the same in PBXact as its part of the core and framework in FreePBX which PBXact uses the same thing.

Hi Tony

Issue remains the same. I’ve been asked to delete the rom file from the tftp folder… which I will do today.

I’m not running the lastest firmware, have not been advised by support to move to this, and the release notes do not refer to s500 and EXP100 modules.

I recommend using the latest firmware. It was 3 months of bug fixes rolled up into a huge release and I know Jason is working on getting release notes more updated as it really was the wrapup of like 7 firmware releases we could not make public due to little issues QA kept finding.

Hi Tony.

So would I download that firmware to one of my firmware slots, then remove the fw46.rom file from that location?

The info from support is to remove fw46.rom from /tftpboot/Sangoma/<0,1,2>

Correct but newer firmware packages don’t include the older no longer used fw46.rom but verify after downloading the latest it’s not in the folder.

Hi Tony

The current firmware package does still include fw46.rom

drwxr-xr-x 2 asterisk asterisk 4.0K Nov 12  2017 8430
drwxr-xr-x 2 asterisk asterisk 4.0K Feb 14 10:15 9430
-rwxr-xr-x 1 asterisk asterisk 5.7M Jun  2 03:44 fw100.rom
-rwxr-xr-x 1 asterisk asterisk  16M Jun  2 03:44 fw205.rom
-rwxr-xr-x 1 asterisk asterisk  16M Jun  2 03:44 fw300.rom
-rwxr-xr-x 1 asterisk asterisk 7.7M Jun  2 03:44 fw305.rom
-rwxr-xr-x 1 asterisk asterisk  16M Jun  2 03:44 fw400.rom
-rwxr-xr-x 1 asterisk asterisk  16M Jun  2 03:44 fw405.rom
-rwxr-xr-x 1 asterisk asterisk 5.7M Jun 26 08:47 fw46.rom
-rwxr-xr-x 1 asterisk asterisk  18M Jun  2 03:44 fw500.rom
-rwxr-xr-x 1 asterisk asterisk  18M Jun  2 03:44 fw700.rom
-rwxr-xr-x 1 asterisk asterisk  12M Jun  2 03:44 fw705.rom
-rwxr-xr-x 1 asterisk asterisk  156 Jun  2 03:43 version

more version

DB20    0400_0003

We added fw46.rom back in yesterday but its the same as the fw100.rom now. We did that as otherwise if you had a slot that had the older fw46.rom from 2 years ago and updated firmware it would leave the old fw46.rom in place since it was not being replaced so now we replace it but its the same as the fw100.rom

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.