Exitwithtimeout in queues

queue
Tags: #<Tag:0x00007f4f47339828>

(Mihailo) #1

Hello,

Not necessarily a problem here but I can’t find the where “Exit with Timeout” setting can be set in a queue? As the first screenshot below shows I’m getting calls classified as Exit with Timeout, how can I tweak this?

According to wiki.asterisk.org

“EXITWITHTIMEOUT(position|origposition|waittime) - The caller was on hold too long and the timeout expired. The position in the queue when the timeout occurred, the entry position, and the amount of time waited are logged”

But where is this set in the queue settings?

Trust this all makes sense!

Mihailo


#2

queues > Timing and Agents > Max Wait Time


(Mihailo) #3

Hi,

Max Wait Time is set to “Unlimited” so surely the call should remain in the queue until the caller hangs up?


#4

correct


(Mihailo) #5

So why are calls getting terminated with this Exitwithtimeout description? I’m baffled!


#6

excellent question.

Could be a bug in the queue module or the reporting.

Have you tried a test call to see how long it takes for a call to time out? If you can get it to happen and you can reproduce the same timing several times it may give you a clue. I would then post logs here for people smarter than me with this stuff to look at.


(Mihailo) #7

Hmmm…not easy to test because it’s a live call centre and I don’t think there’s an easy way of telling the agents not to answer my call.

I guess I could grep the logs and pull up several calls with Exitwithtimeout and post them here…


#8

or you just have to work after hours (if there is such a thing for the call center). welcome to IT :slight_smile:


(Mihailo) #9

Can’t find “Exitwithtimeout” in the logs. Have tried the full log and queue log and drawn a blank. Could it be in some other log?

Mihailo


(David55) #10

It is definitely written to the queue log, e.g.:

According to the source code there two things that will trigger this:

  1. exceeding the queue expiry time;
  2. exceeding the call attempt timeout, if retries have been disabled for the caller.

I assume the first is set with the Max Wait Time setting in FreePBX. On a quick search, I couldn’t find any GUI option for the second, but it was a quick search and the documentation may have been out of date.


(system) closed #11

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.