Exit 255 when trying to apply config. restapp not starting

Upgraded to latest version and now we can’t make outbound calls. Inbound to the main number fails as well.

exit: 255
Unable to continue. Call to undefined function FreePBX\modules\endpoint_apiApp() in /var/www/html/admin/modules/restapps/Restapps.class.php on line 1314
#0 /var/www/html/admin/libraries/Composer/vendor/filp/whoops/src/Whoops/Run.php(383): Whoops\Run->handleError(1, ‘Call to undefin…’, ‘/var/www/html/a…’, 1314)
#1 [internal function]: Whoops\Run->handleShutdown()
#2 {main}

I did list the modules and I found endpointman which seems to be installed:
endpointman | 13.0.7.18 | Enabled | GPLv2+
So I tried reinstalling to see if that helps:
[[email protected] log]# fwconsole ma install -f endpointman
Endpoint Manager Installer
Update Version Number to 13.0.7.18
Generating CSS…Done
Module endpointman successfully installed

But no luck. I still show the service as stopped even though it looks like it is starting and I get the same error when trying to apply the config.
[[email protected] log]# fwconsole restart restapps
Running FreePBX shutdown…

RestApps Server is not running

Running FreePBX startup…
Unable to run Pre-Asterisk hooks, because Asterisk is already running on PID 19002 and has been running for 2 hours, 50 minutes, 37 seconds
Running Asterisk post from Restapps module
Starting RestApps Server…
[>---------------------------] 1 sec
Started RestApps Server. PID is 29744

Looks like endpoint is only partly installed. Try reinstalling it (‘fwconsole ma install endpoint’)

That wouldn’t have anything to do with you not being able to make or receive calls, however.

Module not found:
[[email protected] log]# fwconsole ma install endpoint
Unable to install module endpoint:

  • Cannot find module
fwconsole ma downloadinstall endpoint

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.