Excluding Let's Encrypt Certificate Information from Backup? Warm Restore Failing

Hi there.

I am running 2 FreePBX Distro systems. One is the primary and the other is configured as a warm spare using these steps: Warm Spare PBX 15+ Setup - PBX GUI - Documentation. Failover is being done with smart DNS records.

I have a Let’s Encrypt SSL certificate set up on the primary server as sip.companyname.com.

It appears as though the daily backup/restore activity taking place is copying and restoring the SSL certificate from the primary server to the warm spare server. This results in the actual restore process to the warm spare server failing because the SSL certificate copied to the warm spare doesn’t match up with the API URL’s for the warm spare configuration in the backup job settings on the primary server:


Is there any way to prevent the Let’s Encrypt certificate information from the primary server copying over the backup server to correct this error and allow the warm restore to complete successfully? I’ve already disabled the certificate manager module from the backup job but it’s still copying over the SSL certificate from the primary server it seems.

Thank you.

Bump… any advice here? It would be greatly appreciated!

Bump?.. Could really use a pointer here or at least someone to tell me that using the warm spare method with Let’s Encrypt SSL won’t work.

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.