Exchange 2010 Voice Mail from FreePBX 2.9

For the life of me I can’t figure out why my voice mails aren’t going to the exchange server. Its now 2 am :slight_smile: What a night! Here is what I have in extensions_override.conf

Any variables I might have to change here?

; ARG1 - extension
; ARG3 - RETURN makes macro return, otherwise hangup
exten => s,1,Macro(user-callerid,SKIPTTL)

exten => s,n,GotoIf($[“foo${DB(${BLKVM_OVERRIDE})}” != “fooTRUE”]?vmx,1)
exten => s,n,Noop(CAME FROM: ${NODEST} - Blocking VM cause of key: ${DB(BLKVM_OVERRIDE)})
exten => s,n,Hangup

exten => vmx,1,GotoIf($["${ARG2}" = “DIRECTDIAL”]?3)
exten => vmx,2,SIPAddHeader(Diversion:tel:${ARG1};reason=no-answer;screen=no;privacy=off)
exten => vmx,3,Dial(SIP/exchange-vm)
exten => vmx,4,Hangup

Have you properly configured your SMTP settings? Verified you can send mail from the console via your Exchange SMTP server?