Exception Can not write to the LESS cache folder after update to 14

I did the update to on Friday. This morning however I’ve discovered that none of the remote extensions are working. They are Sangoma phones so I went to Endpoint manager to see if I could tell what’s going on. As soon as I select the menu I get:

Can not write to the LESS cache folder at /var/www/html/admin/modules/endpoint/assets/less/cache. Please run (from the CLI): fwconsole chown::

However that didn’t do anything but create another error. > fwconsole chown
No such command ’ fwconsole chown’ Not sure what that was all about. I started a new SSH connection and was able to run fwconsole chown but none of the remote phones are connecting. I can now get into Endpoint manager, but the status is empty.

It does tell me to click and submit a ticket, which I did.

Update: The GUI appears to be working now so I’ll call this “solved”. I’m unable to get any remote phones to connect but I’ll put that is a different thread.

Did you make any changes to make the GUI work?.. I assume that was some corrupted tables.

I had been unable to run any fwconsole commands from the SSH. All I did was exit my SSH session and start a new one. I was then able to run the fwconsole chown command, which reported being successful. After that I was able to open the Endpoint Manager without getting an error. The rest of the GUI was working in the first place, and still is.

The only thing I’ve found that still isn’t working is that none of my Sangoma phones are getting registered so they aren’t showing up in Extension Mapping and obviously aren’t working. They were working prior to the update and I didn’t make any changes to their settings.

Few things:

  1. Check if the remote WAN IP is banned.
  2. Try to save and rebuild the phone config in Extension Mapping.
  3. Try to reboot the remote phones so it’ll try to re-register - monitor asterisk -rvvvv to see if the phones are trying to register.

The remote WAN IPs are not banned.
I can do a save and rebuilt, but since the phone IP isn’t connected in the VPN nothing will happen.
I have already rebooted the remote phones several times. I don’t see anything happening in Asterisk as the phones come online. And the Status overview in the Responsive firewall never changes from zeros.

I logged into my Sangoma portal and looked at the phone list there. The last time it shows a poll was in September 2017. Not sure if that means anything or not.

Did you reboot the phones after you rebuilded config?

Since you deal with VPN, i’m not sure it you’ll need a new VPN client for the phones…+

Edit: I see Andrew answered you here Failure after update to 14

Andrew jumped on the other thread and solved it. VPN Server - disabled, then enabled. Done. YES!

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.