Everytime a new PBX, extensions keep going on and offline


#1

A few times now, I have put up new PBX, replacing the old one.

Every single time, the same thing happens: Many of the extensions will keep going on and offline constantly for about one day. On and offline every few seconds.

Here is a paste of the SIP debug

https://pastebin.freepbx.org/view/60b9e730

Anyone know this happens?


#2

You have extensions 1255, 1147, 111 and 3603 all registered from 47.41.44.68:1024, apparently a residential cable modem. Is this a gateway from Spectrum? Is there a separate router/firewall?

Most likely, the trouble is either a SIP ALG (disable it if possible, otherwise using nonstandard ports at both ends may help), or a short UDP timeout in the router (increase it if possible, otherwise shorter registration expiry or keep-alive may help).

Possibly related, why did you “replace” the PBX? If the old one wasn’t working properly, what attempts did you make to troubleshoot and fix the problem? If it was running fine, what were you trying to accomplish?

Probably unrelated, why the apparently random extension numbers on a small system? Why chan_sip? Why did you change the chan_sip port to 5060?


#3

It was not doing this until I put up the new PBX. As mentioned, this has happened on different upgrades. As for chan_sip on port 5060 I did not change it. This is originally a FreePBX 2.11 install, then later upgraded to FreePBX 13, and now 15.

I replaced the PBX because we needed more hard drive space and it was on a KVM. Since the drive was ext3 and not LVM, we could not expand the drive o just went ahead and upgraded.

Maybe the router on site needs a reboot.


#4

Try setting Local SIP Port on each phone in a given location to different values.


#5

What do you mean by that?


#6

I saw one phone was a Yealink so I used their terminology. In their web interface, on the Account tab, selecting the active account, Advanced subtab, there is a parameter Local SIP Port that defaults to 5060. Set it to e.g. 5070 in one phone, 5071 in the second phone, 5072 in the third and 5073 in the fourth. I am hoping that in the absence of source port number conflicts, the router will not rewrite the port numbers, and Asterisk will see 5070, etc.

If a phone uses more than one Account (multiple Line buttons are active), you can set the port for all accounts the same (the phone will process the packets according to the user name).


#7

I am not seeing any such setting.


#8

Here is a screenshot from my old Yealink. Do you see something similar?


#9

No, it looks completely different now


#10

Sorry, they moved it to setting -> SIP.


#11

Thanks. I will give it a try tomorrow, if needed


#12

That really helped out. Usually, I see once the telephone is connected, the PBX will shift a telephone to another port to connect with instead of always using port 5060.

Thanks for your time.