Even with Pause and DND, calls still go to static agents

Despite confirming that agents are properly activating both global pause for their extension and server-based DND, calls continue to route to static members of queues. This seems to have become a problem after the most recent batch of updates to FreePBX applied via the module system.

Our temporary workaround is to have all agents log into queues dynamically instead of setting static agents–but we do not want to keep it this way. Ideas?