Eth0 and eth1 switched after kernel update


#1

I’m running SNG7 distro. After running yum update, the kernel got update from 3.10.0-957.10.1.el7.x86_64 to 3.10.0-957.21.3.el7.x86_64 and my ethernet cards got their names switched, so I lost registration and since I have no resets left, my FreePBX is now unactivated.

GRUB already has biosdevname=0 and net.ifnames=0 so it is not supposed to rename ethernet cards.

I tried creating the file 70-persistent-net.rules on /lib/udev/rules.d and /etc/udev/rules.d but it doesn’t make any difference. If I add the parameter HWADDR on ifcfg-eth0 and ifcfg-eth1, systemctl just fails to start the network service, so I don’t know what else to try. If I boot to the previous kernel, the interfaces get their names set as supposed, so there must me something different with the new kernel regarding ethernet naming.

Is anybody running a FreePBX server with 2 ethernet cards and got their names switched after the kernel update?


(Dave Burgess) #2

https://www.centos.org/forums/viewtopic.php?t=42758 looks like a good tutorial to look at.


#3

This procedure doesn’t seem to work on CentOS 7. In any case, I had to resign myself and accept the names being switched. I just re-assigned the IPs switching them to the new names.


(system) closed #4

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.