Errors during firstboot on new install

Hi all.
I am a total beginner in FreePBX but I do have experience in Ubuntu both GUI and CLI. I was asked to help reinstall a machine that was installed with (as far as I could figure out) separate Red Hat as a base, Asterisk 1.8.4 and FreePBX 2.9.
To avoid installing Ubuntu, then Asterisk and FreePBX I decided to give the latest stable FreePBX distro a go (with Asterisk 1.8.13 and FreePBX 2.10.58). At home it installed just fine in virtual box because at that time I couldn’t test it on the target machine.

Today, first try and it doesn’t work. :frowning:
The install looks fine, the server has only single disk so I use the freepbx-noraid option. Goes without a glitch.

However, during first boot it starts throwing out errors, to finish with somethine like that there were errors during firstboot, to run /etc/ later and press Enter to continue.

One possible error I could see during boot, was that the module for the TE122 card couldn’t load the firmware. Followed one google link how to find the correct rpm according to the exact kernel, and did a rpm --install. Rebooted the server and the firmware message is gone, but there is still the message about the firstboot.

The server has two cards, digital TE122 for E1 line, and analog TDM400p for 3 analog lines. Another curious thing I noticed during boot is it seems it’s loading wct4xx (or similar) for the TDM400p while in /etc/dahdi/modules says the correct module for that card is something like wctdm.

So, after the long introduction, first big question: Can these firstboot errors be because of the cards?

If it means something, the server is a HP ML110 G4 with Xeon 3040, 512MB ram (yeah, only 512MB), and 500GB single disk.

There are two other interesting things:

  1. In the old install, before reinstalling it, I noticed on the DAHDi page in the FreePBX web interface that it said module used wctdm24xxp which according to dahdi is not the correct module for neither of the two cards.
  2. After doing the new install and the firstboot error message it shows, if I type the server IP in the browser I get the web interface as normal. Clicking on FreePBX administration shows up the login page, NOT the page it should show the first time asking you to configure user and password. It just says to log in as if it exists. I tried admin/admin and no luck. Tried blank/admin, nothing. I even tried asterisk/asterisk. Nothing.
    I don’t know what to try since I never configured them.

Anyone has any ideas about this whole install process? I am happy to provide any log files, just tell me what to check and how. I can do that in the morning at work (in my time zone).

Alternatively, I don’t mind installing everything from source but what put me off was a lack of a good, short and precise tutorial. I tried with Ubuntu + Asterisk (so far so good), but once you start instaling FreePBX there are too many packages needed to figure out and install before that. Even if you get over that, you have to start touching apache config so that it run as asterisk user, change various things, etc. Never got even to a working web interface.
If there is any good tutorial, even better based on ubuntu or debian, I would appreciate a link.

Thanks in advance to anyone who thinks can help, I really need to get this working (and want to, I want to learn it).


Check this tutorial:

Do you have any questions??? Post it!!!



Install the cards after you install the distro.

Don’t load anything from RPM’s.

That will fix your issue.

Thanks for your interest. This has been resolved. It seems the errors during first boot related to not being able to download a firmware for TE122. Not sure if the FreePBX distro should be able to do that on first boot or not.

Anyway, after adding the firmware manually it looks fine. The error is gone.