Errors applying config after installing Zulu

After I install Zulu on my FreePBX 13 system, I’m unable to apply config. I’ve tried both the edge and non edge versions of the Zulu module and I’ve tried with the sangomacrm module installed and uninstalled but that hasn’t made a difference.
Has anyone else experienced this issue?

The errors I see on attempting to apply config are below:

exit: 255
Unable to continue. There was an error loading class ‘Sangomacrm’ in /var/www/html/admin/modules/zulu/Zulu.class.php on line 518
#0 /var/www/html/admin/modules/zulu/Zulu.class.php(817): FreePBX\modules\Zulu->processCallpopType(‘Sangomacrm-url’)
#1 /var/www/html/admin/libraries/BMO/DialplanHooks.class.php(107): FreePBX\modules\Zulu->doDialplanHook(Object(extensions), ‘asterisk’, 900)
#2 /var/lib/asterisk/bin/retrieve_conf(864): FreePBX\DialplanHooks->processHooks(‘asterisk’, Array)
#3 {main}

Thanks in advance for any suggestions or help!

fwconsole ma downloadinstall sangomacrm

Thanks! I’d tried that previously but I gave it one more go.
It generates more errors on the apply config:

exit: 255
Unable to continue. No default driver in /var/www/html/admin/modules/sangomacrm/Sangomacrm.class.php on line 159
#0 /var/www/html/admin/modules/sangomacrm/Sangomacrm.class.php(674): FreePBX\modules\Sangomacrm->getDefaultDriver()
#1 /var/www/html/admin/modules/sangomacrm/Sangomacrm.class.php(68): FreePBX\modules\Sangomacrm->getCallPopURL()
#2 /var/www/html/admin/modules/zulu/Zulu.class.php(539): FreePBX\modules\Sangomacrm->processCallpopValue(‘Sangomacrm-url’, ‘…’)
#3 /var/www/html/admin/modules/zulu/Zulu.class.php(822): FreePBX\modules\Zulu->processCallpopValue(‘Sangomacrm-url’, ‘…’)
#4 /var/www/html/admin/libraries/BMO/DialplanHooks.class.php(107): FreePBX\modules\Zulu->doDialplanHook(Object(extensions), ‘asterisk’, 900)
#5 /var/lib/asterisk/bin/retrieve_conf(864): FreePBX\DialplanHooks->processHooks(‘asterisk’, Array)
#6 {main}

Then uninstall it. If you still have the error then you set it up previously and now it’s confused so you’ll have to go set it up again.

I’ve tried uninstalling and reinstalling both zulu and the sangomacrm modules multiple times.
Is there a way to manually make sure all of the previously set up items are removed?

I do get the following error when I try to uninstall the sangomacrm module:

  • Failed to run un-installation scripts
    Is there a way to manually run those scripts? That’s probably the better question here.

Did you previously setup Sangoma CRM? Seems like you did?

We had a trial license quite some time ago.
I grabbed another trial license, reinstalled, edited the CRM settings and I was able to Apply Config successfully. However, I’m still getting the error when I attempt to uninstall the sangomacrm module.

I’m not sure, but you can try

fwconsole ma delete sangomacrm

Thanks! I’d tried that already and it didn’t take care of the errors.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.