Errors applying changes, unable to register from Zoiper

Hello, I am trying to deploy an Asterisk server. This is my first attempt using FreePBX after testing an Ubuntu text-based Asterisk. I did not have problems with my text-based Asterisk, but in FreePBX I am not able to register the user in Zoiper 5.

My FreePBX version is and is installed in a VMWare ESXi virtual machine, with 16GB HD and 1GB RAM. After the successful installation, I have configured my network, my language and my keyboard layout. I have activated my server, and then, I have created 2 pjsip extensions and applied config. It was strange for me that applying changes took a long time (over 10 minutes).

When tried to log in Zoiper, another strange thing is that zoiper doesn’t find my sip udp configuration. My text-based Asterisk does. I try to log in anyway, but I get error 401. Something is wrong in my server setup.

Monitor (asterisk -rvvv) shows nothing when softphone is trying to register. Command “sip show users” shows nothing. Command “sip show peers” shows nothing.

I suspect config is not been applied, so I run “fwconsole r --verbose” with no changes.

Things I checked:

  • ping is ok
  • firewall is disabled
  • intrusion detection is disabled
  • asterisk service is running
  • changed secret to a strong one
  • reboot server

I don’t know what I miss and what happen with my server. Any help will be appreciated. Thanks in advance.

I have monitored Asteriks during applying changes and I get a lot of errors:

  • db.c:304 db_execute_sql: Error executing SQL (COMMIT): database is locked
  • res_pjsip_config_wizard.c:1091 object_type_loaded_observer: Unable to load config file ‘pjsip_wizard.conf’
  • iax2/firmware.c:235 iax_firmware_reload: Error opening firmware directory ‘/var/lib/asterisk/firmware/iax’: No such file or directory
  • res_smdi.c:1441 reload: No SMDI interfaces were specified to listen on, not starting SDMI listener.

Is this FreePBX DIstro or did you install it on top of another OS?

I ask because PJSIP is now in use by default for FreePBX distrom unless you made a chan_sip extension instead of a PJSIP one

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.