Errors after upgrade

This morning I did the scripts update from on my FreePBX built from the ISO.

Following the update I’m running into a couple of problems and had to fall back on my backup Trixbox system until I can get these issues resolved.
The System Admin shows that I’m on PBX Service Pack running on IP

During bootup I’m getting an error:
Error: wanpipe configuration file not found: /etc/wanpipe/wanpipe1.conf

I have confirmed there is no such file but what do I do about it?

2)Also I’m seeing an error ipmi_si: Invalid return from get global enables command, can not enable the event buffer.

3)I need to change the IP of the system from to I’ve tried to make the change in the Admin->Admin->Network Settings screen but it never changes. I put in the new IP, click save settings, reboot, and it comes back with the old IP. I’ve tried logging onto the new IP before rebooting as well but as expected, it times out. For some reason it’s not changing the IP on reboot however (On Boot: is set to Yes)

Help on any or all of these issues is appreciated. I’m a bit of a novice on Linux so step-by-step instructions are much appreciated.

Below are the lines showing errors from the log. I can post the entire log if needed but of course it’s a lot of lines.

[2012-01-23 09:56:56] DEBUG[3265] xmldoc.c: Cannot find variable ‘description’ in tree ‘MEETME_INFO’
[2012-01-23 09:56:56] VERBOSE[3265] pbx.c: == Registered custom function ‘MEETME_INFO’
[2012-01-23 09:56:56] VERBOSE[3265] loader.c: => (MeetMe conference bridge)
[2012-01-23 09:56:56] VERBOSE[3265] pbx.c: == Registered application ‘ConfBridge’
[2012-01-23 09:56:56] VERBOSE[3265] loader.c: => (Conference Bridge Application)
[2012-01-23 09:56:56] VERBOSE[3265] pbx.c: == Registered custom function ‘DEVICE_STATE’
[2012-01-23 09:56:56] VERBOSE[3265] pbx.c: == Registered custom function ‘HINT’
[2012-01-23 09:56:56] VERBOSE[3265] loader.c: => (Gets or sets a device state in the dialplan)
[2012-01-23 09:56:56] WARNING[3265] cdr_manager.c: Failed to load configuration file. Module not activated.
[2012-01-23 09:56:56] ERROR[3265] cdr_syslog.c: Unable to load cdr_syslog.conf. Not logging custom CSV CDRs to syslog.
[2012-01-23 09:56:56] WARNING[3265] cel_manager.c: Failed to load configuration file. CEL manager Module not activated.
[2012-01-23 09:56:56] ERROR[3265] cel_custom.c: Unable to load cel_custom.conf. Not logging CEL to custom CSVs.
[2012-01-23 09:56:56] VERBOSE[3265] loader.c: => (Customizable Comma Separated Values CEL Backend)
[2012-01-23 09:56:56] ERROR[3265] cdr_custom.c: Unable to load cdr_custom.conf. Not logging custom CSV CDRs.

[2012-01-23 09:56:56] ERROR[3265] app_amd.c: Configuration file amd.conf missing.

[2012-01-23 09:56:56] NOTICE[3265] pbx_ael.c: Starting AEL load process.
[2012-01-23 09:56:56] NOTICE[3265] pbx_ael.c: File /etc/asterisk/extensions.ael not found; AEL declining load

[2012-01-23 09:56:57] ERROR[3265] res_clialiases.c: res_clialiases configuration file ‘cli_aliases.conf’ not found

[2012-01-23 09:56:57] WARNING[3265] app_festival.c: No such configuration file festival.conf
[2012-01-23 09:56:57] ERROR[3265] ais/clm.c: Could not initialize cluster membership service: Try Again

[2012-01-23 09:56:57] WARNING[3265] app_minivm.c: Failed to load configuration file. Module activated with default settings.

[2012-01-23 09:56:57] WARNING[3265] app_followme.c: No follow me config file (followme.conf), so no follow me
[2012-01-23 09:56:57] VERBOSE[3265] file.c: == Registered file format mp3, extension(s) mp3
[2012-01-23 09:56:57] VERBOSE[3265] loader.c: => (MP3 format [Any rate but 8000hz mono is optimal])
[2012-01-23 09:56:57] ERROR[3265] chan_unistim.c: Unable to load config unistim.conf

[2012-01-23 09:56:57] ERROR[3265] pbx_dundi.c: Unable to load config dundi.conf

The wanpipe error is because you don’t have Sangoma hardware.

The rest of the stuff is just unused dial plan. Nothing to worry about.

Change the ip in /etc/sysconfig/network-scripts/ifcfg-eth0

Change it with your favorite editor, then run a “service network restart”.

I am not a big fan of changing network settings in a GUI.

Ok. I’ll edit the file that says not to edit this file in all capital letters.

On the old version the GUI change worked as soon as it was rebooted but it’s not working in this new version. Appears to be a bug.


Not debating with you but i did a brand new install of Trixbox CE and I get this error and I have two Sangoma Cards a T1/E1 Card and an FXO 4 port card. I don’t think it’s what you described because of this fact.

I am looking for resolution for this and will post it when I find it.

Nexus - Looking for resolution for what? Thew missing wanpip config? If you have Sangoma cards did you run setup-sangoma? That generates the file.