Errors adding extensions / IVR / Ring group


#21

Maybe - just to do a simple test:

  • make a new SIP extension (SIP or PJSIP depending on what you are using)
  • call that extension and leave voicemail
  • see if works as expected

(United States) #22

No, it is different.

Twice now, the VM is completely locked up, and I have to force restart to get back in. I don’t get what’s going on here and why it’s just all of a sudden. It’s completely maddening. I’m at the point where I’ll pay someone to fix it…


(United States) #23

Looking at the CDR, even though I get a VM, my call is never being reported…


(Andrew) #24

You’ve been asked for the call logs of your last test, and the result of the command I posted. I can’t help you if you don’t try what I am suggesting.


(United States) #25

how else can I? Pastebin is down and the log is twice the limit of this reply box…


(United States) #26

NM. Try this, I just went to their site instead of the PBX one:


(Andrew) #27

There are multiple calls in the log. Which one is it?


(United States) #28

The one ending in 0806 I believe


(Andrew) #29

That is a call to a page group.

The other call in here does go to VM.

[2021-09-13 07:25:42] VERBOSE[835][C-0000417b] pbx.c: Executing [[email protected]:2] VoiceMail("SIP/outvoipms-000003ee", "[email protected],u") in new stack
[2021-09-13 07:25:42] VERBOSE[835][C-0000417b] file.c: <SIP/outvoipms-000003ee> Playing '/var/spool/asterisk/voicemail/default/116/unavail.slin' (language 'en')
[2021-09-13 07:25:53] VERBOSE[835][C-0000417b] file.c: <SIP/outvoipms-000003ee> Playing 'vm-intro.ulaw' (language 'en')
[2021-09-13 07:25:59] VERBOSE[835][C-0000417b] file.c: <SIP/outvoipms-000003ee> Playing 'beep.ulaw' (language 'en')
[2021-09-13 07:25:59] VERBOSE[835][C-0000417b] app_voicemail.c: Recording the message
[2021-09-13 07:25:59] VERBOSE[835][C-0000417b] app.c: x=0, open writing: /var/spool/asterisk/voicemail/default/116/tmp/eFaYpB format: wav, 0x7f4adc5cf680
[2021-09-13 07:26:05] VERBOSE[835][C-0000417b] app.c: User hung up

Is the call intended to go to 116? Is it just a problem with the email notification?


(United States) #30

Correct. Page group rings 2 extensions (1 after the other), after 20 sec, it should forward to 116’s VM.

I just placed 4 test calls. The 1st one went through and rang the extensions and dumped me into 116’s VM. The next 3 calls, completely skipped the ring group and just dumped straight to 116’s VM and do not show up on the CDR report. I get the IVR (press 0-5) but after that it hits VM instead of the ring group…it’s completely random in it’s working or not


(Andrew) #31

So your issue is with calls going through a page group not going to VM? I’m not familiar with FreePBX page groups enough to tell you what the issue is but based on what I can tell in the log of that call at no point does it attempt to go to voicemail.


(United States) #32

Right…that’s part of the problem. She said she GOT VM and left a message but it was never delivered. And then there’s the 2nd part that it’s just skipping the ring group and just going to VM…but sometimes it works as expected.


(United States) #33

/var/log/asterisk/full:[2021-09-15 00:32:43] DTMF[12603][C-0000000d] channel.c: DTMF begin ‘0’ received on SIP/outvoipms-0000000d
/var/log/asterisk/full:[2021-09-15 00:32:43] DTMF[12603][C-0000000d] channel.c: DTMF begin ignored ‘0’ on SIP/outvoipms-0000000d
/var/log/asterisk/full:[2021-09-15 00:32:43] DTMF[12603][C-0000000d] channel.c: DTMF end ‘0’ received on SIP/outvoipms-0000000d, duration 120 ms
/var/log/asterisk/full:[2021-09-15 00:32:43] DTMF[12603][C-0000000d] channel.c: DTMF end passthrough ‘0’ on SIP/outvoipms-0000000d

Am I reading this right? It saw my 0 entered, but ignored it?


(United States) #34

Ok last post for the night…I figured just to get them by, until we can figure out the issue, I’d just set the inbound route to their main phone. Just bypass the 5 options and have that 1 person manually route calls. First few test calls just ring straight to her phone as I’d expect. Then randomly the IVR start announcing itself again. The recording starts and asks for option 0-5 even though the inbound route is STILL set to extension…What the heck?!


#35

Is there any chance that you have more than just one inbound route? Maybe another inbound route is taking over in association to a time condition?


(United States) #36

Unfortunately no; just the 1 route.


(United States) #37

Update 9/16 I restored using a backup from 2-3 weeks ago. Now if I click on any extensions, try to add a IVR, or pretty much anything I get similar errors to this…hoping there is a quick fix…

Exception thrown with message “Array
(
[name] => Main Incoming_COPY_
[alertinfo] =>
[description] => Main - Regular
[announcement] => 2
[directdial] => Disabled
[invalid_loops] => 3
[invalid_retry_recording] => default
[invalid_destination] =>
[invalid_recording] => default
[retvm] =>
[timeout_time] => 10
[timeout_recording] => default
[timeout_retry_recording] => default
[timeout_destination] =>
[timeout_loops] => 3
[timeout_append_announce] => 0
[invalid_append_announce] => 0
[timeout_ivr_ret] => 0
[invalid_ivr_ret] => 0
[rvolume] => 0
[strict_dial_timeout] => 2
)
SQLSTATE[42S22]: Column not found: 1054 Unknown column ‘strict_dial_timeout’ in ‘field list’::”

Stacktrace:
#4 Exception in /var/www/html/admin/libraries/utility.functions.php:207
#3 die_freepbx in /var/www/html/admin/modules/ivr/functions.inc.php:467
#2 ivr_save_details in /var/www/html/admin/modules/ivr/functions.inc.php:431
#1 ivr_configprocess in /var/www/html/admin/libraries/components.class.php:469
#0 component:processconfigpage in /var/www/html/admin/config.php:450


(system) closed #38

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.