Error with priority skipdb

Hi guys

ive been using freepbx for a long time, and works great. now i want some help 'cause im kinda stuck in the middle of something.

i got some kind of procedure that before making a call, connects to a DB and extract some info from the caller and then… do this

exten => _XXXX,n,Set(CALLERID(NAME)=${DB(AMPUSER/${CALLERID(NUMBER)}/cidname)})
exten => _XXXX,n,Dial(LOCAL/${EXTEN}@dundi-extens/n,300,tTg)

and the context contain this:
[dundi-extens]
include => ext-findmefollow
include => ext-local
switch=> DUNDi/activos

when the context dial to it, it just fail and i ve found this:

[Feb 18 12:18:34] VERBOSE[8145] app_dial.c: – Called [email protected]/n
[Feb 18 12:18:34] VERBOSE[8152] pbx.c: – Executing [[email protected]:1] GotoIf(“Local/[email protected];2”, “0?ext-local,1110,1”) in new stack
[Feb 18 12:18:34] VERBOSE[8152] pbx.c: – Executing [[email protected]:2] Macro(“Local/[email protected];2”, “user-callerid,”) in new stack
[Feb 18 12:18:34] VERBOSE[8152] pbx.c: – Executing [[email protected]:1] Set(“Local/[email protected];2”, “AMPUSER=1120”) in new stack
[Feb 18 12:18:34] VERBOSE[8152] pbx.c: – Executing [[email protected]:2] GotoIf(“Local/[email protected];2”, “1?report”) in new stack
[Feb 18 12:18:34] VERBOSE[8152] pbx.c: – Goto (macro-user-callerid,s,10)
[Feb 18 12:18:34] VERBOSE[8152] pbx.c: – Executing [[email protected]:10] GotoIf(“Local/[email protected];2”, “0?continue”) in new stack
[Feb 18 12:18:34] VERBOSE[8152] pbx.c: – Executing [[email protected]:11] Set(“Local/[email protected];2”, “__TTL=64”) in new stack
[Feb 18 12:18:34] VERBOSE[8152] pbx.c: – Executing [[email protected]:12] GotoIf(“Local/[email protected];2”, “1?continue”) in new stack
[Feb 18 12:18:34] VERBOSE[8152] pbx.c: – Goto (macro-user-callerid,s,19)
[Feb 18 12:18:34] VERBOSE[8152] pbx.c: – Executing [[email protected]:19] NoOp(“Local/[email protected];2”, “Using CallerID “Adriana Grandas” <1120>”) in new stack
[Feb 18 12:18:34] VERBOSE[8152] pbx.c: – Executing [[email protected]:3] Set(“Local/[email protected];2”, “__EXTTOCALL=1110”) in new stack
[Feb 18 12:18:34] VERBOSE[8152] pbx.c: – Executing [[email protected]:4] GotoIf(“Local/[email protected];2”, “1?skipdb”) in new stack
[Feb 18 12:18:34] WARNING[8152] pbx.c: Priority ‘skipdb’ must be a number > 0, or valid label
[Feb 18 12:18:34] VERBOSE[8152] pbx.c: == Spawn extension (dundi-extens, 1110, 4) exited non-zero on ‘Local/[email protected];2’
[Feb 18 12:18:34] VERBOSE[8152] pbx.c: – Executing [[email protected]:1] Macro("Local/[email protected];2"s , “hangupcall,”) in new stack

the piece of code is from the extensions_additional.conf context

[ext-findmefollow]
.
.
.
exten => 1110,n,Set(__EXTTOCALL=${EXTEN})
exten => 1110,n,noop(================$${BLKVM_OVERRIDE}==============)
exten => 1110,n,GotoIf($[“foo${BLKVM_OVERRIDE}” = “foo”]?skipdb)<—the error?
exten => 1110,n,GotoIf($["${DB(${BLKVM_OVERRIDE})}" = “TRUE”]?skipov)
exten => 1110,n(skipdb),Set(__NODEST=)
exten => 1110,n,Set(__BLKVM_OVERRIDE=BLKVM/${EXTEN}/${CHANNEL})
exten => 1110,n,Set(__BLKVM_BASE=${EXTEN})
exten => 1110,n,Set(DB(${BLKVM_OVERRIDE})=TRUE)
exten => 1110,n(skipov),Set(RRNODEST=${NODEST})
exten => 1110,n(skipvmblk),Set(__NODEST=${EXTEN})
exten => 1110,n,GosubIf($[${DB_EXISTS(AMPUSER/1110/followme/changecid)} = 1 & “${DB(AMPUSER/1110/followme/changecid)}” != “default” & “${DB(AMPUSER/1110/followme/changecid)}” != “”]?sub-fmsetcid,s,1)
exten => 1110,n,Set(RecordMethod=Group)
.
.
.
.

but when i disable my piece of code let them through freepbx normaly this error does not happen.

So what can i be doing wrong or how can i fix this?

my system got:

asterisk 1.6.2.5
freepbx 2.8.0
centos 5.5
on vmware 4

Thanks !!