Error with Endpoint and Sysadmin

Running FreePBX 12.0.13. I just purchased the Sys Admin module from Schmooze yesterday.

When I try to launch System Admin, I see the following:

FATAL ERROR

FreePBX is Unable to Continue

Cant find Endpoint::: Cant find Endpoint

Trace Back

/var/www/html/admin/modules/sysadmin/Sysadmin.class.php:403 Hooks->processHooks()

/var/www/html/admin/modules/sysadmin/functions.inc/license.php:329 Sysadmin->getModuleLicenseInformation()
[0]: name

/var/www/html/admin/modules/sysadmin/page.sysadmin.php:53 sysadmin_is_module_licensed()
[0]: sysadmin_exp

/var/www/html/admin/config.php:509 include()
[0]: /var/www/html/admin/modules/sysadmin/page.sysadmin.php

When I try to launch Module Admin, the only thing displayed is the header:

Module Administration

Any suggestions on how I might correct these problems?

I’ve just disabled sysadmin-12.0.9.6 which appears to be causing this issue. We’re looking at this right now.

How can I disable it if Module Admin is not available?

1 Like

try

amportal a ma uninstall endpoint

If that doesnt work try:

rm -Rf /var/www/html/admin/modules/endpoint

[[email protected] ~]# amportal a ma uninstall endpoint

Fetching FreePBX settings with gen_amp_conf.php…

The following error(s) occured:

  • Cannot disable: The following modules depend on this one: restapps

Should I try your second suggestion?

Actually, uninstall restapps and endpoint

OK, that seemed to work. I could successfully launch Module Admin with a warning that:

You have some broken FreePBX Modules. We advise you take care of these as soon as possible: View

Broken

endpoint 12.0.0.29 Stable Broken
Info
Description: No description is available.
More info: Get help for endpoint
Action: No Action Install Uninstall

You mean

amportal a ma uninstall restapps?

It’s OK, you’re back up, we’re now releasing a fixed endpoint, and I’ll re-enable them both for download 8)

Thanks so much for your quicker-than-quick, successful solution.

1 Like

Thanks Rob,

That was hurting us also :smile:

1 Like

This should be fixed in endpoint 12.0.0.30 sorry guys. :heart:

Is this available in Module Admin yet? I don’t see it after Checking Online. Maybe I’m too anxious.

Oh, I see, I was supposed to install it.

What is Endpoint Manager? Is this the Sysadmin module? If it is, there’s no DDNS on it.

i don’t think .30 fixed the problem. as soon as i install .30 the module admin goes away and the error for sysadmin comes back. i uninstalled restapps and endpoint and then installed endpoint .30.

I just ran into the same problems updated to .30 everything seems to be fine. However when I go into the extension manager in the Endpoint and I click “Add Extension” Nothing happens.

It has a javascript problem
According to chrome devtools

config.php?display=endpoint&view=extensions:9 Uncaught SyntaxError: Unexpected token ,

Use module rollback and go back to .28

It did for others. Maybe try a few more times. I will check again on another system

Edit: Just checked on another system and .30 is fine.

How do I perform the rollback?

Go to module admin. Check online. Then go to Endpoint. Then click it. Then click rollback then select said version.

I also confirmed your javascript issue.

I moved a post to a new topic: Updated Sysadmin Lost Features