Error when creating self signed certificate

I’m having a problem with self signed certificates on a Sangoma phone system 40 device.
It is running Freepbx V13.0.192.16
I have all the modules up to date.
I’m doing the setup for a new deployment and everthing is working fine so far.
I’m at the point where I am setting up secure connections for the management and UCP websites.
The first time I went to certificate managment and set the default certificate (the one that is created when Freepbx is activated).
Then went to system admin - https setup - settings and selected the certificate and clicked install.
Then I went to system admin - port management and set the admin to port 1443 and ucp to 443 and hit aupdate now. (just a note, I have tried other combinations with the same results).
When I try to connect to the site using with IE or Chrome, I get an error and can’t continue to the site.
I use both of these browsers to connect to other system that I manage that use self signed certificates, so I am familiar with how to connect when the self signed certificate is used.
I have tried to generate new certificates and set them as default, etc, with the same results.
The actual error in Chrome is
"xxxxx normally uses encryption to protect your information. When Google Chrome tried to connect to xxxx this time, the website sent back unusual and incorrect credentials. This may happen when an attacker is trying to pretend to be xxxxx, or a Wi-Fi sign-in screen has interrupted the connection. Your information is still secure because Google Chrome stopped the connection before any data was exchanged.

You cannot visit xxxxx right now because the website sent scrambled credentials that Google Chrome cannot process. Network errors and attacks are usually temporary, so this page will probably work later."
I even went so far as to reboot the server, without and change.

Any ideas are welcome.