Error when clicking apply config

PBXact Version 10.13.66-21 When I click apply config, I get a red notification in the right hand side of the screen that says:
Symfony\Component\Process\Exception\ProcessFailedException The command “cd /var/www/html/admin/modules/pm2/node && mkdir -p /home/asterisk/.pm2 && mkdir -p /var/www/html/admin/modules/pm2/node/logs && export HOME=/home/asterisk && export PM2_HOME=/home/asterisk/.pm2 && export ASTLOGDIR=/var/log/asterisk && export ASTVARLIBDIR=/var/lib/asterisk && export PATH=$HOME/.node/bin:$PATH && export NODE_PATH=$HOME/.node/lib/node_modules:$NODE_PATH && export MANPATH=$HOME/.node/share/man:$MANPATH && /var/www/html/admin/modules/pm2/node/node_modules/pm2/bin/pm2 jlist” failed. Exit Code: 127(Command not found) Working directory: /var/www/html/admin Output: ================ Error Output: ================ /usr/bin/env: node: No such file or directory File:/var/www/html/admin/libraries/Composer/vendor/symfony/process/Process.php:221
Then a window pop up Error: Did not receive valid response from the server XHR response code: 500 XHR responseText: undefined jQuery status: error

Ive run all the updates. What next?

Delete iSymphony using the fwconsole command.

I ran these commands https://issues.freepbx.org/browse/FREEPBX-10725 and now apply config works.
However, the dashboard shows Restapps, UCP, Xmpp and Zulu Daemons are not running. And when I log into the UCP there’s a red bar across the top that says Unable to connect to the UCP Node Server because: ‘timeout’

So you updated the nodejs and UCP stuff?

The red bar makes sense if the UCP service didn’t restart. Have you rebooted the machine to make sure all of the updates were applied correctly and are being used?

I rebooted the pbx. Now its all showing ok in the dashboard except UCP node is not running.

What version of Asterisk are you on?

Asterisk 13.23.1

Why?

fwconsole pm2 --restart ucpnode

Ran that command. It says Process restarted, but it still shows not running in dashboard, even after multiple refreshes.

fwconsole pm2 --list

ucpnode PID 0 Status Errored Restarts 30 Uptime 0

Are all modules up to date?

If not,

fwconsole ma upgradeall
fwconsole reload

if they are,

fwconsole ma downloadinstall pm2 --force
fwconsole reload

Then try again to start the process

All up to date. Ran the pm2 command and it installed succesfully. However, ucp still not runnning. Ran the list command and still shows ucpnode errored and 16 restarts.

Try

fwconsole restart ucpnode

Not sure if it’s going to help.

Why are you on a unsupported version. You need to upgrade to the SNG7 version of your PBXact Sysytems.

You uninstalled nodejs. You need to reinstall it. That is your issue.

When installing pm2 isn’t it checking for nodejs dependency?

[[email protected] ~]# yum install nodejs
Loaded plugins: fastestmirror, kmod
Setting up Install Process
Loading mirror speeds from cached hostfile
base | 2.0 kB 00:00
extras | 1.3 kB 00:00
pbx | 2.9 kB 00:00
schmooze-commercial | 2.9 kB 00:00
updates | 1.3 kB 00:00
Package nodejs-0.12.18-1nodesource.el6.x86_64 already installed and latest version
Nothing to do
I’d be happy to upgrade to SNG7 but bricked the last box I tried that on and had to do a clean install instead of upgrade. Fortunately it was only a test box. This is in customers businesss. If there is a stable way to upgrade it now, I’ll look into it.

This is what I get when I click view log in Sys admin update module.

From the bash prompt:

/usr/sbin/sysadmin_update_system --unlock