Error updating user info in user manager


I am running into some error when updating user info in user manager. Trying to change email address throws error:

An Unknown error occured while trying to update user data

For testing, i tried to change user description and get error :

SQLSTATE[42S02]: Base table or view not found: 1146 Table 'asterisk.srtapi_chat_users' doesn't exist

I tried downgrading useradmin module to previous version but same thing happens.

Im not sure how to approach this troubleshooting. Any tips or idea of direction i can explore to fix? I feel like its related to some module (lol) Thank you for any suggestions :stuck_out_tongue:

My guess is you need to install the sangoma realtime api module

1 Like

You are a genius! That did it.

I think I know what led up this. I had upgraded all modules through terminal (fwconsole ma install upgrade all). then I thought oh, i don’t need these commercial modules let me uninstall them assuming that they were installed from the upgrade command I ran.

I wish I paid attention to what modules are installed by default bc clearly some are required even if not used. I can load up a fresh install to compare unless its an easy answer of “all of them”.

Thank you very much for responding to my post. :slight_smile:

Since user management is oss and rtapi is not, we definintely don’t want it to be a dependency. If you can provide the steps to repro this error, please open a bug ticket at

I just tried it, starting with a stock 16 Distro system, I removed the sangomartapi module and no issues with updating userman details.

1 Like

Will do. I can test that on new fresh install to get the reproduction steps noted, I think I recall exactly the order of steps I went through. Like a bonehead, I uninstalled literally every commercial module so ill make sure to make a list. Thanks guys!

I would imagine it had something to do with an apply config and a stale hook for userman.

1 Like

Just to update this thread, We have reproduced reported issue in-house , raised [FREEPBX-23814] Error updating user info in user manager - Sangoma Issue Tracker and solution in sangomartapi module also pushed to the edge.



This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.