Error Unable to write to /etc/wanpipe/global.conf

Getting the error:

Error Unable to write to /etc/wanpipe/global.conf

Please change permissions on /etc/wanpipe/global.conf or disable Sangoma DIGIUM mode
Added 1 minute ago
(dahdiconfig.SANGOMA)

Here is a screenshot of the error

Got this after I downloaded latest Repositories in Freepbx 2.11 Distro
PBX Firmware: 5.211.65-6

Do you use dahdiconfig? Do you have the file /etc/wanpipe/global.conf?

Yes, I used dahdiconfig.

I does not appear that I have /etc/wanpipe/global.conf file
nano /etc/wanpipe/global.conf does not bring up an existing file

I noticed my business can still receive phone calls, but the system will no longer allow phone calls out!

[2014-02-22 13:56:13] VERBOSE[2238][C-00000005] pbx.c: – Executing [[email protected]:32] Set(“SIP/109-00000005”, “CHANNEL(language)=en”) in new stack
[2014-02-22 13:56:13] VERBOSE[2238][C-00000005] pbx.c: – Executing [[email protected]:2] Set(“SIP/109-00000005”, “ROUTEUSER=109”) in new stack
[2014-02-22 13:56:13] VERBOSE[2238][C-00000005] pbx.c: – Executing [[email protected]:3] GotoIf(“SIP/109-00000005”, “1?restrictedroute-0,2045551212,2:outbound-allroutes,2045551212,2”) in new stack
[2014-02-22 13:56:13] VERBOSE[2238][C-00000005] pbx.c: – Goto (restrictedroute-0,2045551212,2)
[2014-02-22 13:56:13] WARNING[2238][C-00000005] pbx.c: Channel ‘SIP/109-00000005’ sent to invalid extension but no invalid handler: context,exten,priority=restrictedroute-0,2045551212,2

Unable to write to /etc/wanpipe/global.conf
Delete thisIgnore this
Please change permissions on /etc/wanpipe/global.conf or disable Sangoma DIGIUM mode
Added 1 minute ago
(dahdiconfig.SANGOMA)

I got my calling out working again, but still have global.conf error.
Turns out this last Repositories Update caused it to stop working and required me to download and register the Extensions Routing Module. Logged into Schmooze Com, Inc, place the order for $0.00, it was approved 1/2 hour later, followed their instructions in their email, rebooted, put my extensions into the Unblocked area and now I can make calls out again.

You could have just uninstalled the Extension Routing Module, as what happened was you downloaded it but then never activated it causing your own issues. We do not and never will require people to use a commercial module.

I never purposefully selected that module to download and install so unsure how it got into my system.

We do not remote download and install modules without your knowledge so, yes, at some point you clicked and told it to install or you’ve had it sitting there for a while or you accidentally selected it when attempting to upgrade other modules

I have a zero byte global.conf, permissions set to 777 and a Sangoma A200 card and get the same error message.

Unable to write to /etc/wanpipe/global.conf
Delete thisIgnore this
Please change permissions on /etc/wanpipe/global.conf or disable Sangoma DIGIUM mode
Added 10 seconds ago
(dahdiconfig.SANGOMA)

It seemed to start with the last Dahdi Config module update (2.11.37).
HTH

Restored to an earlier system image that ran Dahdi config 2.11.36
and the “unable to write” issue went away. I don’t know if it’s of any help, but with 2.11.36, the

Run Wanpipe In DAHDI Mode:

option/listing is there and is not in 2.11.37.

Regards,

“Run Wanpipe In DAHDI Mode” was merged with the other setting in 2.11.37

If you are using the Dahdi config module and have a zero byte global.conf file then something has been wrong for a long long time. That file should have write access and the module needs to be able to write to it. I see a small subset of users with this issue however I have not been able to replicate it.

I was able to replicate it. Fix is in 2.11.38

Cool! Thank you!

Excellent. thanks.