Error restoring from backup


#1

Declaration of FreePBX\modules\Backup\Handlers\Restore\Legacy::process($use
inmemory) should be compatible with FreePBX\modules\Backup\Handlers\Restore
\Common::process()


(Dave Burgess) #2

This is the second time this week this has shown up. Have you checked to see if there’s a ticket in on this issue yet?


(Shahin Nazir) #3

Hi @kensikora,
Pls try to update your PBX exist Backup module to edge version.

fwconsole ma --edge downloadinstall backup
fwconsole chown
fwconsole r --verbose

Thanks.

Shahin


#4

I updated using the commands above on the new PBX and get the same error.


(Shahin Nazir) #5

Hi @kensikora

If you update Backup Module to EDGE version, fixed folders/files permissions and still you can see same error message i think you should open Support Ticket at Sangoma. How to @cynjut suggested you before.

Thanks.

Shahin


(gchpx) #6

Hi all,

i also have the same issue and wanted to ask if @cynjut got his error resolved?

Thanks for an Info!


(Dave Burgess) #7

It wasn’t my error, I’d just noticed that it had come up a couple of times and wanted to know if someone had submitted a ticket.

The answer that we did get was to do the following:


(Kapil Gupta) #8

I can see https://issues.freepbx.org/browse/FREEPBX-21959 reported today with a similar issue and I asked the user to try with the latest edge release i.e. v15.0.10.38.

Please update Jira issue, if the v15.0.10.38 release also has the same issue present?

please use the below command to check your installed backup module to confirm you are using the latest edge.

fwconsole ma list|grep backup

thanks