Error quick setting up extensions (RESOLVED)

UPDATE:

I upgraded the framework and got a new error when try to do the same thing. If I tell it no for voicemail the extension is created. However Id like voicemail to be working.

Hello,

Please upgrade the voicemail and core module to latest release. I hope it will fix the issue.

Thanks

They are both upgraded and up to date per module admin.still not working.

Hi @abuehrlen
Pls check first your PBX DNS settings

127.0.0.1
8.8.8.8
8.8.4.4
Your Privet DNS

Then update your module signatures and check all update modules.

fwconsole sa u
fwconsole ma refreshsignatures
fwconsole ma upgradeall
fwconsole chown
fwconsole r --verbose

Thanks.

What is output of:

 fwconsole ma list | egrep "core|voicemail"

when running fwconsole sa u I get:

Updating license for
Done!
No changes from original Licence.

when running fwconsole ma refreshsignatures everything shows good except:

Checking builtin…
Signature Invalid
Could not find signed module on remote server!

When running fwconsole ma upgrade all I get:

[[email protected] src]# fwconsole ma upgradeall
No repos specified, using: [standard,extended] from last GUI settings

Up to date.
Updating Hooks…Done

When running fwconsole chown I Get:

Setting Permissions…
Setting base permissions…Done
Setting specific permissions…
20630 [============================]
Finished setting permissions

When I run fwconsole r --verbose I get:

Reloading FreePBX
exit: 0
touch: cannot touch `/etc/asterisk//etc/asterisk/extensions_custom_scripter.conf’: No such file or directory
[ERROR] Error code 1: trying to create empty file /etc/asterisk/"/etc/asterisk/extensions_custom_scripter.conf"
Please update your modules and reload Asterisk by browsing to your server.
Successfully reloaded

Any further help would be appreciated.

| core | 13.0.131 | Enabled | GPLv3+ |
| voicemail | 13.0.59.3 | Enabled | GPLv3+ |
| voicemail_report | 13.0.13.3 | Enabled | Commercial |
[[email protected] src]#

coincidentally still getting the error after running those commands.

Latest release is:-
| voicemail | 13.0.59.5 | Enabled | GPLv3+ |

When I go to admin and module admin in the gui and click check online it says its up to date. How do i update it?

Try with
fwconsole ma downloadinstall voicemail --tag 13.0.59.5

2 Likes

Ok I updated it and then tried again and it worked. No More Error. Thank You Very Much I appreciate it.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.