Error on module upgrade

Large Module update today. Error on Apply Config:

FreePBX 13.0.113

What can I do to try and fix this?

exit: 1
Exception: Permissions error on /home/asterisk/.gnupg - please re-run as root to automatically repair in file /var/www/html/admin/libraries/BMO/GPG.class.php on line 749
Stack trace:
  1. Exception->() /var/www/html/admin/libraries/BMO/GPG.class.php:749
  2. FreePBX\GPG->checkPermissions() /var/www/html/admin/libraries/BMO/GPG.class.php:261
  3. FreePBX\GPG->getKey() /var/www/html/admin/libraries/BMO/GPG.class.php:326
  4. FreePBX\GPG->trustFreePBX() /var/lib/asterisk/bin/retrieve_conf:42

Two thoughts.

  1. Run the update again.
  2. use the fwconsole restart to run the permission checks in the Frepbx environment. (There’s a more direct way to do it, but don’t recall it)

Thanks Marc.

The update was not available because it was waiting to Apply Config.

I ran fwconsole restart, then Apply Config worked!

Thank you

My pleasure. I’se had the same type of issue a few times myself.

Pretty much any time you see the words ‘permissions error’, running ‘fwconsole chown’ will fix it, in any situation. You don’t need to restart.

(This statement is for people googling this in the future - Hi, future peeps! Did I ever get a Telsa?)

<<<—Fwconsole chown— >>>