ERROR: No FAX modules detected!

The “restoring from centos to ubuntu” saga, leads me to a new problem:

On the “fax” section of extensions, a red warning appears :

ERROR: No FAX modules detected!
Fax-related dialplan will NOT be generated.
This module requires Fax for Asterisk ( or spandsp based app_fax ( to function.

on my ubuntu /usr/lib/asterisk/modules only is present while on same centos directory is also present.

What should I do to restore the original centos fax features also on Ubuntu machine ?

Thank you

You would need to compile spandsp then recompile asterisk with the spandsp that you have installed. This is why you should be using a Distro and not trying to hand install something. It will be non stop issues.

I have the same problem since updating,but are using freepbx distro:

Your Linux Distribution: (Redhat CentOS release 6.2 (Final))
Your FreePBX version: (2.11.0)
PBX Firmware: 2.210.62-5
PBX Service Pack:
Asterisk 11.3.0

Fax Configuration

Seems i fixed it by running asterisk-version-switch

Also make sure you are updating using the FreePBX upgrade scripts for the Distro as found at

“This is why you should be using a Distro and not trying to hand install something.”

So why do you realease the FreePBX software as a stand-alone product? Just withdraw it and release the distro only. If you give candy for free and afterwards say to the kids “you shouldn’t eat the free candies, it’s bad for you”, why in the hell do you give the candies?

Seems trolling to me.

Hi Henry,

There are things we do in the distro such as compile span_dsp that we could never do at the FreePBX level, we do however provide users tips and help on how to install all of this for those that want to do it by hand for whatever suits them. We clearly state when fax isn’t working and we clearly give out solutions for how to fix it. Your remarks about “withdraw it and release the distro only” sounds more like trolling me to. We provide the distro for an easy end user experience, that doesn’t mean anyone (or everyone) has to use it.

Furthermore the software (FreePBX) is GPL, we can not and will never ever close source on it, this doesn’t mean fax will only work in the distro, it just means our paid developers have spent the time getting it to work in the distro. Asterisk out of the box does not turn faxes into PDFs, we add that by compiling span_dsp which turns it into PDFs.

As I said we clearly state what doesnt work and then when people ask we clearly state what and how to fix it. We are not saying “you cant do it without using the distro” we are just saying it will be more difficult.

Are you also saying that since FreePBX requires Asterisk but if you don’t install the distro you must install it yourself by hand that we should also scrap the source because the FreePBX installer doesnt compile asterisk?

Here’s a tutorial on how to install span_dsp:

Questions and comments are welcome. Please keep in mind that we don’t have to provide the “free” (it does not cost you to download it, it costs us) distro to anyone.

If you use openSUSE with Asterisk and FreePBX (oh, how I hate my boss…) and your fax doesn’t work, chances are you don’t have the asterisk-spandsp package installed.

Just install it and it will work.
YAST is your friend.

and its that easy to install? Is it just a package in the openSUSE repo?

Hi guys, I am also getting the message in any of my extensions configuration screens. The complete message is:
ERROR: No FAX modules detected!
Fax-related dialplan will NOT be generated.
This module requires Fax for Asterisk ( or spandsp based app_fax ( to function.

My setup is your standard distro (no changes) and a TDM400 card for 4 analog lines.

I tried asterisk-version-switch but I get a command not found error.
As proposed in other thread I did a yum install asterisk-version-switch but I get a No package asterisk-version-switch available error.
I tried a yum update, which upgraded many things:
(1/46): asterisk-11.8.1-1_centos6.i686.rpm | 3.7 kB 00:00
(2/46): asterisk-core-11.8.1-1_centos6.i686.rpm | 8.0 MB 00:09
(3/46): asterisk-dahdi-11.8.1-1_centos6.i686.rpm | 869 kB 00:00
(4/46): asterisk-doc-11.8.1-1_centos6.i686.rpm | 13 kB 00:00
(5/46): asterisk-odbc-11.8.1-1_centos6.i686.rpm | 227 kB 00:00
(6/46): asterisk-voicemail-11.8.1-1_centos6.i686.rpm | 265 kB 00:00
(7/46): asterisknow-version-3.0.1-2_centos6.noarch.rpm | 6.4 kB 00:00
(8/46): bind-libs-9.8.2-0.23.rc1.el6_5.1.i686.rpm | 891 kB 00:03
(9/46): bind-utils-9.8.2-0.23.rc1.el6_5.1.i686.rpm | 181 kB 00:00
(10/46): coreutils-8.4-31.el6_5.1.i686.rpm | 3.0 MB 00:07
(11/46): coreutils-libs-8.4-31.el6_5.1.i686.rpm | 50 kB 00:00
(12/46): dahdi-linux-2.9.0-1_centos6.i686.rpm | 2.6 kB 00:00
(13/46): dahdi-tools- | 271 kB 00:01
(14/46): ethtool-3.5-1.2.el6_5.i686.rpm | 97 kB 00:00
(15/46): gnutls-2.8.5-13.el6_5.i686.rpm | 340 kB 00:00
(16/46): initscripts-9.03.40-2.el6.centos.1.i686.rpm | 940 kB 00:01
(17/46): irqbalance-1.0.4-8.el6_5.i686.rpm | 38 kB 00:00
(18/46): kernel-2.6.32-431.5.1.el6.i686.rpm | 26 MB 01:01
(19/46): kernel-firmware-2.6.32-431.5.1.el6.noarch.rpm | 13 MB 00:35
(20/46): kernel-headers-2.6.32-431.5.1.el6.i686.rpm | 2.8 MB 00:06
(21/46): kmod-dahdi-linux-2.9.0-1_centos6.2.6.32_279.14. | 4.2 MB 00:06
(22/46): kmod-dahdi-linux-fwload-vpmadt032- | 133 kB 00:00
(23/46): libsrtp-1.4.4-4.20101004cvs.el6.i686.rpm | 274 kB 00:00
(24/46): libtiff-3.9.4-10.el6_5.i686.rpm | 339 kB 00:00
(25/46): libtonezone- | 17 kB 00:00
(26/46): mysql-5.1.73-3.el6_5.i686.rpm | 903 kB 00:04
(27/46): mysql-libs-5.1.73-3.el6_5.i686.rpm | 1.2 MB 00:03
(28/46): mysql-server-5.1.73-3.el6_5.i686.rpm | 8.8 MB 00:19
(29/46): nss-3.15.3-6.el6_5.i686.rpm | 826 kB 00:01
(30/46): nss-sysinit-3.15.3-6.el6_5.i686.rpm | 40 kB 00:00
(31/46): nss-tools-3.15.3-6.el6_5.i686.rpm | 368 kB 00:02
(32/46): openldap-2.4.23-34.el6_5.1.i686.rpm | 267 kB 00:00
(33/46): openssl-1.0.1e-16.el6_5.4.i686.rpm | 1.5 MB 00:04
(34/46): p11-kit-0.18.5-2.el6_5.2.i686.rpm | 93 kB 00:00
(35/46): p11-kit-trust-0.18.5-2.el6_5.2.i686.rpm | 68 kB 00:00
(36/46): postfix-2.6.6-6.el6_5.i686.rpm | 2.0 MB 00:05
(37/46): psmisc-22.6-19.el6_5.i686.rpm | 80 kB 00:00
(38/46): python-2.6.6-52.el6.i686.rpm | 74 kB 00:00
(39/46): python-libs-2.6.6-52.el6.i686.rpm | 5.3 MB 00:10
(40/46): speex-1.2-0.12.rc1.1.el6.i686.rpm | 88 kB 00:00
(41/46): tzdata-2014a-1.el6.noarch.rpm | 448 kB 00:01
(42/46): upstart-0.6.5-13.el6_5.3.i686.rpm | 168 kB 00:00
(43/46): wget-1.12-1.11.el6_5.i686.rpm | 482 kB 00:01
(44/46): yum-plugin-fastestmirror-1.1.30-17.el6_5.noarch | 28 kB 00:00
(45/46): yum-plugin-security-1.1.30-17.el6_5.noarch.rpm | 38 kB 00:00
(46/46): yum-utils-1.1.30-17.el6_5.noarch.rpm | 102 kB 00:00

After the upgrade I rebooted but still no luck.
Please can you give me advice on where to look?
Any help is appreciated.
Best regards,Marcos.

Yes, tm1000.

You have asterisk, dahdi, span-dsp and almost everything you need prepackaged on openSUSE repos to build a functioning Asterisk setup. You only have to install FreePBX by hand, which is very easy.

I had my share of trouble mixing openSUSE and Asterisk/FreePBX in the past, but things are pretty smooth now. It’s a matter of choosing the right packages in YaST and you’re good. You can even choose from Asterisk 1.4, 1.6, 1.8, 10 and 11.

Almost no configuration is needed, besides setting up your phone exchange & features in FreePBX. There are some catches, but nothing too hairy.

I dont think you are using our Distro.

What does the following command show

cat /etc/schmooze/pbx-version

Hi Tony, sorry my bad. I am using AsteriskNOW.
I am new to the Asterisk community and I am learning in every step I take … I guess that the fact of having a single image installed with no compiling or customizations with every single link pointing to your GUI support site got me confused. Sorry about that.
I am currently following their procedure for installing the software and license.
Thank you for your help.