FreePBX | Register | Issues | Wiki | Portal | Support

Error: "name lookup timed out" (DNS is okay)


(Mauro Rafael Dos Santos) #1

Hi guys!

I have some problems to active my FreeBPX… I tried the activation in System Admin but the error “name lookup timed out” appears.

I runned the cli command to activate but the this error appears:

[root@localhost bin]# fwconsole sysadmin activate deployment
Attempting to activate against deployment 'deployment’
Running /var/www/html/admin/modules/sysadmin/bin/activate_existing deployment
Asking for deployment deployment…Error!
Unable to track down your deployment

My DNS is okay, all my modules is updated and I deleted all my deployments in sangoma portal. This error occur with or without firewall enabled.
In my local network the FreePBX is working (softphones and mobiles) but I want to start to use outside, with a line provider and some features, so I need to activate the FreePBX.
Any help is welcome.

Asterisk 13


(Steven Sedory) #2

Same issue right now on a new install


(Steven Sedory) #3

Resolved:

After looking at this post Cannot activate after upgrade to 10.13.66

I did the following from the cli:
vi /etc/resolv.conf (then used the vi editor to change DNS from my local DNS to 8.8.8.8 and 8.8.4.4)
then ran service network restart, service httpd restart, and service asterisk restart

Was able to active after.

EDIT: DNS kept setting back to my local DNS during activation, so it would get the same error at the end. You need to set a static IP, static gateway, and static DNS through the cli to get it to work. Here’s my notes for reference:

//Static client
vi /etc/sysconfig/network-scripts/ifcfg-InterfaceName (eth0)
HWADDR=xx:xx:xx:xx:xx:xx
TYPE=Ethernet
ONBOOT=yes
NM_CONTROLLED=no
BOOTPROTO=static
IPADDR=x.x.x.x
NETMASK=x.x.x.x
(if there are any other lines of config here, you can leave alone)
//default route
vi /etc/sysconfig/network
GATEWAY=x.x.x.x
//DNS client
vi /etc/resolv.conf
nameserver x.x.x.x
nameserver x.x.x.x

Then run each of the following: service network restart, service httpd restart, and service asterisk restart


(Lorne Gaetz) #4

Network and DNS settings are configurable in System Admin.


(Steven Sedory) #5

Unless you haven’t activated your install yet, and the only options in System Admin are Activation and Support.


(Mauro Rafael Dos Santos) #6

Steven, thanks but my DNS is okay… this is not a DNS connection problem. I can make update and ping other servers with no problem.


(Marbled) #7

Hi!

Is this in a real DMZ (real as opposed to a home router definition of a DMZ) where you have to grant permission on a per port basis?

DNS usually use port 53 UDP but switches to port 53 TCP when the replies gets too long (or for zone transfers but this doesn’t apply here).

The DNS queries could appear to work if only port 53 UDP is allowed but could fail when it has to switch to port 53 TCP…

If the problem is not that then I wonder if the “name lookup timed out” might not be the actual error but something more like this:

It’s a different problem but it probably implicates the same servers and maybe you are not getting the right error message… Is your IP “new”?

Good luck and have a nice day!

Nick


(Mauro Rafael Dos Santos) #8

Marbled, thank you to try to help me. I build a new VM on my server with a fresh FreePBX install and in this installation the problem didn´t appears.
I don´t know what is the problem, but I spended a lot of time trying to fix them.
I’ll use this new installation… and reconfigure all settings, probably this is the best to do now.
But, any way, thanks to all.


(Douglas Hammond) #9

Disabled ipv6 and my similar issue was fixed.


Upgrade to v14 error > Network